summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@hundin.mysql.fi>2002-08-08 03:14:44 +0300
committerunknown <monty@hundin.mysql.fi>2002-08-08 03:14:44 +0300
commita9c47d8cfc9d93dd93409c3d3681a4f726a456e5 (patch)
treee700bcb0baacd3c2e36818839eb18c8744ddf5dd /configure.in
parent7448e105224e2b3808789ab2b77e0268acf45321 (diff)
downloadmariadb-git-a9c47d8cfc9d93dd93409c3d3681a4f726a456e5.tar.gz
Fix for Intel compiler (ecc)
Minor cleanups to other patches. Make --temp-pool default Docs/manual.texi: Changelog configure.in: Fix for Intel compiler (ecc) include/my_global.h: Cleaned up QNX specific code. include/my_pthread.h: Safety include/my_semaphore.h: Cleaned up BSDI fix. mysys/my_pthread.c: Code comments mysys/my_semaphore.c: Fix for BSDI sql/mysqld.cc: Make --temp-pool default sql/sql_parse.cc: Safety
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 144447d4cb6..7e48522dbf0 100644
--- a/configure.in
+++ b/configure.in
@@ -1554,6 +1554,17 @@ AC_SUBST(TERMCAP_LIB)
#########################################################################
dnl Checks for library functions.
+
+#
+# The following code disables intrinsic function support while we test for
+# library functions. This is to avoid configure problems with Intel ecc
+# compiler
+
+ORG_CFLAGS="$CFLAGS"
+if test "$GCC" != "yes"; then
+ AC_SYS_COMPILER_FLAG(-nolib_inline,nolib_inline,CFLAGS,[],[])
+fi
+
AC_FUNC_MMAP
AC_TYPE_SIGNAL
MYSQL_TYPE_QSORT
@@ -1576,6 +1587,8 @@ AC_CHECK_FUNCS(alarm bmove \
pthread_condattr_create rwlock_init pthread_rwlock_rdlock \
fchmod getpass getpassphrase initgroups mlockall)
+CFLAGS="$ORG_CFLAGS"
+
# Sanity check: We chould not have any fseeko symbol unless
# large_file_support=yes
AC_CHECK_FUNCS(fseeko,