summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2005-10-18 15:43:59 +0200
committerunknown <msvensson@neptunus.(none)>2005-10-18 15:43:59 +0200
commit69585b215b6ca854f9a0757787242df30193946f (patch)
tree710b8c5ba5604cf18f75c3f2e6e10ccc0fcb9003 /configure.in
parentb50eb4cd42d2d5073afb2af5af8b19c825a9cca1 (diff)
downloadmariadb-git-69585b215b6ca854f9a0757787242df30193946f.tar.gz
Bug #12985 Do-mysqlclient-test: Can't find -lyassl when linking
- Use yassl_includes and yassl_libs instead of openssl_includes and openssl_libs to avoid that mysql_config returns that libyassl and libtaocrypt are needed for linking. client/Makefile.am: Add yassl_includes config/ac-macros/yassl.m4: Use own variables for yassl, don't intrude on openssl configure.in: Add yassl_libs to lib_DEPENDENCIES and CLIENT_LIBS libmysql/Makefile.am: Add yassl_includes libmysql_r/Makefile.am: Add yassl_libs and yassl_includes libmysqld/Makefile.am: Add yassl_includes server-tools/instance-manager/Makefile.am: Add yassl includes and lib sql/Makefile.am: Add yassl includes and libe vio/Makefile.am: Add yassl includes and libe
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 05aaaa73bfa..d06cd0e1af1 100644
--- a/configure.in
+++ b/configure.in
@@ -1139,7 +1139,7 @@ dnl Is this the right match for DEC OSF on alpha?
sql/Makefile.in)
# Use gen_lex_hash.linux instead of gen_lex_hash
# Add library dependencies to mysqld_DEPENDENCIES
- lib_DEPENDENCIES="\$(bdb_libs_with_path) \$(innodb_libs) \$(ndbcluster_libs) \$(pstack_libs) \$(innodb_system_libs) \$(openssl_libs)"
+ lib_DEPENDENCIES="\$(bdb_libs_with_path) \$(innodb_libs) \$(ndbcluster_libs) \$(pstack_libs) \$(innodb_system_libs) \$(openssl_libs) \$(yassl_libs)"
cat > $filesed << EOF
s,\(^.*\$(MAKE) gen_lex_hash\)\$(EXEEXT),#\1,
s,\(\./gen_lex_hash\)\$(EXEEXT),\1.linux,
@@ -2423,7 +2423,7 @@ then
AC_DEFINE([THREAD_SAFE_CLIENT], [1], [Should be client be thread safe])
fi
-CLIENT_LIBS="$NON_THREADED_LIBS $openssl_libs $ZLIB_LIBS $STATIC_NSS_FLAGS"
+CLIENT_LIBS="$NON_THREADED_LIBS $openssl_libs $yassl_libs $ZLIB_LIBS $STATIC_NSS_FLAGS"
AC_SUBST(CLIENT_LIBS)
AC_SUBST(NON_THREADED_LIBS)