summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGeorgi Kodinov <Georgi.Kodinov@Oracle.com>2011-02-02 19:05:28 +0200
committerGeorgi Kodinov <Georgi.Kodinov@Oracle.com>2011-02-02 19:05:28 +0200
commit72ae1d65dd62f1e2cc308549a84a46feadd158f4 (patch)
tree4635605ae0572f713774190b2fe771d0df3a1f96 /configure.in
parente805a0fd9de24cf1a9a6fb7bd10a336dbcd46fe9 (diff)
parenta70c34bf0f34703fd330f8cb828e48b303c5296a (diff)
downloadmariadb-git-72ae1d65dd62f1e2cc308549a84a46feadd158f4.tar.gz
merge to 5.1.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3849c362eec..6d5bc07ba9a 100644
--- a/configure.in
+++ b/configure.in
@@ -1884,6 +1884,15 @@ dnl
MYSQL_CHECK_TIME_T
+dnl
+dnl check size of time_t
+dnl
+
+AC_CHECK_SIZEOF(time_t, 8)
+if test "$ac_cv_sizeof_time_t" -eq 0
+then
+ AC_MSG_ERROR("MySQL needs a time_t type.")
+fi
# do we need #pragma interface/#pragma implementation ?
# yes if it's gcc 2.x, and not icc pretending to be gcc, and not cygwin