summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Widenius <monty@mysql.com>2010-11-29 11:27:52 +0200
committerMichael Widenius <monty@mysql.com>2010-11-29 11:27:52 +0200
commite68ff466534c370b96e96ee3c0b04996ae67ecfd (patch)
tree424de8ecfa893f4b50bd6015971283965ef83f8e /configure.in
parent9ab4829bc6d37e0ffacc016ce09351e9bde8cf81 (diff)
downloadmariadb-git-e68ff466534c370b96e96ee3c0b04996ae67ecfd.tar.gz
Fixed compiler and gmake warnings
- Removed SCCS rule from Makefile.am - Made dummy rule in sql_yacc.yy to get rid of compiler warning about not used label. Don't use maintainer mode with valgrind (as we don't want to initialize all variables) config/ac-macros/maintainer.m4: Don't use maintainer mode with valgrind (as we don't want to initialize all variables) Force initialization of variables when using -Werror (To get rid of compiler warnings) configure.in: Don't use maintainer mode with valgrind (as we don't want to initialize all variables) sql/sql_yacc.yy: Made dummy rule in sql_yacc.yy to get rid of compiler warning about not used label.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 11 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index b6c97ea0aa6..67b6b94340b 100644
--- a/configure.in
+++ b/configure.in
@@ -111,6 +111,17 @@ AC_ARG_WITH([debug],
[with_debug=$withval],
[with_debug=no])
+AC_ARG_WITH([valgrind],
+ [AS_HELP_STRING([--with-valgrind],
+ [Valgrind instrumentation @<:@default=no@:>@])],
+ [], [with_valgrind=no])
+
+if test "$with_valgrind" != "no"
+then
+ AC_CHECK_HEADERS([valgrind/valgrind.h valgrind/memcheck.h],
+ [AC_DEFINE([HAVE_VALGRIND], [1], [Define for Valgrind support])])
+fi
+
# Whether the maintainer mode should be enabled.
MY_MAINTAINER_MODE
@@ -1728,17 +1739,6 @@ else
CXXFLAGS="$OPTIMIZE_CXXFLAGS $CXXFLAGS"
fi
-AC_ARG_WITH([valgrind],
- [AS_HELP_STRING([--with-valgrind],
- [Valgrind instrumentation @<:@default=no@:>@])],
- [], [with_valgrind=no])
-
-if test "$with_valgrind" != "no"
-then
- AC_CHECK_HEADERS([valgrind/valgrind.h valgrind/memcheck.h],
- [AC_DEFINE([HAVE_VALGRIND], [1], [Define for Valgrind support])])
-fi
-
# Debug Sync Facility. NOTE: depends on 'with_debug'. Must be behind it.
AC_MSG_CHECKING(if Debug Sync Facility should be enabled.)
AC_ARG_ENABLE(debug_sync,