summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <bell@sanja.is.com.ua>2006-04-11 14:49:33 +0300
committerunknown <bell@sanja.is.com.ua>2006-04-11 14:49:33 +0300
commitc2ee905473ca0b380c3b952a27691f3411592b8c (patch)
treee87e04040a130ed2207ab6189363350190b8e5d0 /configure.in
parentd7caa2a02aedec5a294bbb0c64aed048f23dc6be (diff)
parente0e74450d6306760144e429d6e0911bdf4da5a84 (diff)
downloadmariadb-git-c2ee905473ca0b380c3b952a27691f3411592b8c.tar.gz
Merge sanja.is.com.ua:/home/bell/mysql/bk/mysql-4.0
into sanja.is.com.ua:/home/bell/mysql/bk/work-4.1 acinclude.m4: Auto merged configure.in: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b230b7f042e..a7ef6546425 100644
--- a/configure.in
+++ b/configure.in
@@ -881,6 +881,9 @@ AC_SUBST(WRAPLIBS)
if test "$TARGET_LINUX" = "true"; then
AC_MSG_CHECKING([for atomic operations])
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+
atom_ops=
AC_TRY_RUN([
#include <asm/atomic.h>
@@ -916,6 +919,8 @@ int main()
if test -z "$atom_ops"; then atom_ops="no"; fi
AC_MSG_RESULT($atom_ops)
+ AC_LANG_RESTORE
+
AC_ARG_WITH(pstack,
[ --with-pstack Use the pstack backtrace library],
[ USE_PSTACK=$withval ],