summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <brian@brian-akers-computer.local>2004-04-12 21:01:45 -0700
committerunknown <brian@brian-akers-computer.local>2004-04-12 21:01:45 -0700
commit01bff53c4f71b9d204bc42b654e73d4ec6e6a941 (patch)
tree686ebbc1135999578321bffc95e6f3aec84ad720 /configure.in
parent83c2292bb5617128bd5c0eaa69663072363b38c7 (diff)
downloadmariadb-git-01bff53c4f71b9d204bc42b654e73d4ec6e6a941.tar.gz
All changes are to allow someone to compile the example storage engine and use it.
acconfig.h: Default undef for example storage engine. acinclude.m4: Build macro additions for example engine. configure.in: Configure changes for it to be listed in --help sql/Makefile.am: Added in paths to build example. sql/examples/ha_example.cc: Correction in indention and a few minor other corrections. It now lets you create/open/drop example engine. sql/handler.cc: Added definition for the example storage engine. Added case for it to be created. sql/handler.h: Added example storage engine type. sql/mysql_priv.h: Added flag for optional build of example storage engine. sql/mysqld.cc: Pieces to build example storage engine.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index de546d9c078..8bfee20972b 100644
--- a/configure.in
+++ b/configure.in
@@ -2618,6 +2618,7 @@ AC_DEFINE_UNQUOTED(MYSQL_DEFAULT_COLLATION_NAME,"$default_collation")
MYSQL_CHECK_ISAM
MYSQL_CHECK_BDB
MYSQL_CHECK_INNODB
+MYSQL_CHECK_EXAMPLEDB
# If we have threads generate some library functions and test programs
sql_server_dirs=