summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <bell@sanja.is.com.ua>2002-03-22 22:55:08 +0200
committerunknown <bell@sanja.is.com.ua>2002-03-22 22:55:08 +0200
commit3d2ac023a0356f72c64487715364232a3bd11abd (patch)
treea691fc4031ec0bdda379decf4651d4789739c5e8 /configure.in
parent58e0b04efc2655cafd2ba46b75c6f59e99aa5459 (diff)
downloadmariadb-git-3d2ac023a0356f72c64487715364232a3bd11abd.tar.gz
added building without query cache
configure.in: new configure parameter (now only for embeded server) include/my_global.h: now query cache always included in server, because of problrms with test suit mysql-test/r/flush.result: removed double testing mysql-test/t/flush.test: removed double testing mysql-test/t/grant_cache.test: now it is only memo about query cache mysql-test/t/query_cache.test: now it is only memo about query cache
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3fe235693e9..8794f0fb884 100644
--- a/configure.in
+++ b/configure.in
@@ -1797,6 +1797,18 @@ AC_ARG_WITH(embedded-server,
[with_embedded_server=no]
)
+AC_ARG_WITH(query_cache,
+ [ --without-query-cache Don't build query cache in embedded server.],
+ [with_embedded_server=$withval],
+ [with_embedded_server=yes]
+)
+
+if test "$with_embedded_server" = "yes"
+then
+ CFLAGS="$CFLAGS -DHAVE_QUERY_CACHE"
+ CXXFLAGS="$CXXFLAGS -DHAVE_QUERY_CACHE"
+fi
+
AC_ARG_WITH(extra-tools,
[ --without-extra-tools Skip building utilites in the tools directory.],
[with_tools=$withval],