summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <sasha@work.mysql.com>2000-11-05 04:19:39 +0100
committerunknown <sasha@work.mysql.com>2000-11-05 04:19:39 +0100
commit9184f1313400781d0e1d4ddb0a0a86d756f743c8 (patch)
tree58acc3b884433336b0ad2dadbf11e25cadecc35c /configure.in
parent42ca0a99874a2b43add6c43b831a7b9311effe9b (diff)
downloadmariadb-git-9184f1313400781d0e1d4ddb0a0a86d756f743c8.tar.gz
configure.in fixed to properly handle 1 digit branch
configure.in: fixed to properly handle 1 digit branch BitKeeper/etc/logging_ok: Logging to logging@openlogging.org accepted
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index bd78c787189..4a8b5dbfa4c 100644
--- a/configure.in
+++ b/configure.in
@@ -16,7 +16,7 @@ SHARED_LIB_VERSION=10:0:0
# Remember that regexps needs to quote [ and ] since this is run through m4
MYSQL_NO_DASH_VERSION=`echo $VERSION | sed -e "s|-.*$||"`
MYSQL_BASE_VERSION=`echo $MYSQL_NO_DASH_VERSION | sed -e "s|\.[[^.]]*$||"`
-F_PART=`echo $MYSQL_BASE_VERSION | sed -e "s|\.||g"| sed -e "s|[[a-zA-Z]]\+||"`
+F_PART=`echo $MYSQL_BASE_VERSION | sed -e "s|\.||g"| sed -e "s|[a-zA-Z]\+||"|sed -e "s|^\(..\)$|\\10|"`
L_PART=`echo $MYSQL_NO_DASH_VERSION | sed -e "s|^[[0-9]]\.[[0-9]]*\.||" | sed -e "s|^\(.\)$|0\\1|" | sed -e "s|[[a-z]]||"`
MYSQL_VERSION_ID=${F_PART}${L_PART}