summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tim@cane.mysql.fi>2001-01-19 02:46:13 +0200
committerunknown <tim@cane.mysql.fi>2001-01-19 02:46:13 +0200
commitc25f29bcdfa381e7116e1e671877a6051c3a898a (patch)
tree05ccbd701e51555fe5537ef3f344c7862d54f5f9 /configure.in
parentfc42688add0116dfdee5fcad8f42f77d909cfda3 (diff)
downloadmariadb-git-c25f29bcdfa381e7116e1e671877a6051c3a898a.tar.gz
Add --with-server-suffix (MYSQL_SERVER_SUFFIX).
configure.in: add --with-server-suffix (MYSQL_SERVER_SUFFIX) include/mysql_version.h.in: add --with-server-suffix (MYSQL_SERVER_SUFFIX) myisam/Makefile.am: add --with-server-suffix (MYSQL_SERVER_SUFFIX) mysql-test/Makefile.am: add --with-server-suffix (MYSQL_SERVER_SUFFIX) scripts/Makefile.am: add --with-server-suffix (MYSQL_SERVER_SUFFIX) scripts/mysqlbug.sh: add --with-server-suffix (MYSQL_SERVER_SUFFIX) sql-bench/Makefile.am: add --with-server-suffix (MYSQL_SERVER_SUFFIX) sql/mysqld.cc: add --with-server-suffix (MYSQL_SERVER_SUFFIX) support-files/Makefile.am: add --with-server-suffix (MYSQL_SERVER_SUFFIX)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 923a10211f5..fe81a5a39ea 100644
--- a/configure.in
+++ b/configure.in
@@ -389,6 +389,14 @@ then
AC_MSG_ERROR([MySQL requiers a ANSI C compiler (and a C++ compiler). Try gcc. See the Installation chapter in the Reference Manual.])
fi
+AC_ARG_WITH(server-suffix,
+ [ --with-server-suffix Append value to the version string.],
+ # I heard that 'cut' isn't portable. Isn't there a better way?
+ [ MYSQL_SERVER_SUFFIX=`echo "$withval" | sed -e 's/^\(...................................\)..*$/\1/'` ],
+ [ MYSQL_SERVER_SUFFIX= ]
+ )
+AC_SUBST(MYSQL_SERVER_SUFFIX)
+
# Set flags if we wants to have MIT threads.
AC_ARG_WITH(mit-threads,
[ --with-mit-threads Always use included thread lib.],