summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@donna.mysql.com>2001-02-07 17:42:20 +0200
committerunknown <monty@donna.mysql.com>2001-02-07 17:42:20 +0200
commitf816d6f16d5c4df073cf0bed40de07286f6c6cd5 (patch)
tree513c37217d346353220e5bf7b3bcccd9e135c596 /configure.in
parente5f835b101afafa7ded3f2660416c3d8bfa995f6 (diff)
downloadmariadb-git-f816d6f16d5c4df073cf0bed40de07286f6c6cd5.tar.gz
Use new bitmap interface
Patches for Armstrong Removed warnings when using REPAIR TABLE .. EXTENDED Docs/manual.texi: Changelog configure.in: Added missing -lsocket library on SCO include/global.h: Patch for Armstrong include/my_bitmap.h: Changed bitmap interface to avoid problem with missing LOCK_bitmap symbol include/myisampack.h: Portability fix for Armstrong mysql-test/t/select.test: Changed to work with 'mysql test < select.tst' mysys/my_bitmap.c: Changed bitmap interface to avoid problem with missing LOCK_bitmap symbol mysys/my_init.c: Removed LOCK_bitmap sql/field.cc: Patch for Armstrong sql/filesort.cc: Patch for Armstrong sql/ha_myisam.cc: Removed warnings when using REPAIR TABLE .. EXTENDED sql/mysql_priv.h: Use new bitmap interface sql/mysqld.cc: Use new bitmap interface sql/sql_select.cc: Use new bitmap interface
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 61a19b67067..828ff2a315d 100644
--- a/configure.in
+++ b/configure.in
@@ -879,9 +879,9 @@ then
MYSQL_REMOVE_SOCKET_FROM_LIBS_HACK
if expr "$CC" : ".*gcc.*"
then
- with_named_thread="-pthread -lnsl"
+ with_named_thread="-pthread -lsocket -lnsl"
else
- with_named_thread="-Kthread -lnsl"
+ with_named_thread="-Kthread -lsocket -lnsl"
fi
if expr "$SYSTEM_TYPE" : ".*unixware7.0.0" > /dev/null
then
@@ -923,7 +923,7 @@ then
if test -f /usr/lib/libthread.so -o -f /usr/lib/libthreadT.so
then
MYSQL_REMOVE_SOCKET_FROM_LIBS_HACK
- with_named_thread="-Kthread -lnsl"
+ with_named_thread="-Kthread -lsocket -lnsl"
if expr "$SYSTEM_TYPE" : ".*unixware7.0.0" > /dev/null
then
AC_DEFINE(HAVE_UNIXWARE7_THREADS)