summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <malff/marcsql@weblab.(none)>2006-08-17 16:08:51 -0700
committerunknown <malff/marcsql@weblab.(none)>2006-08-17 16:08:51 -0700
commitdec9116f4eec68cc15c4e543d1ad372762d20653 (patch)
tree9494137031e44102ca4470248d644c2d05c6f868 /configure.in
parentb747f9732b008efc3dfefb4e0344cfa1b9e14e56 (diff)
downloadmariadb-git-dec9116f4eec68cc15c4e543d1ad372762d20653.tar.gz
WL#3432 (Compile the Parser with a --debug --verbose option)
Changed the automake build process : - ./configure.in - ./sql/Makefile.am to compile an instrumented parser for debug=yes or debug=full builds Changed the (primary) runtime invocation of the parser : - sql/sql_parse.cc to generate bison traces in stderr when the DBUG "parser_debug" flag is set. configure.in: WL#3432 (Compile the Parser with a --debug --verbose option) New Automake condition : MYSQL_CONF_DEBUG sql/Makefile.am: WL#3432 (Compile the Parser with a --debug --verbose option) In Debug mode, compile sql_yacc.yy with --debug --verbose sql/sql_parse.cc: WL#3432 (Compile the Parser with a --debug --verbose option) Conditionally turn the bison parser debug on at runtime.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b49dffcb59f..00a13253166 100644
--- a/configure.in
+++ b/configure.in
@@ -1667,6 +1667,7 @@ else
CFLAGS="$OPTIMIZE_CFLAGS -DDBUG_OFF $CFLAGS"
CXXFLAGS="$OPTIMIZE_CXXFLAGS -DDBUG_OFF $CXXFLAGS"
fi
+AM_CONDITIONAL(MYSQL_CONF_DEBUG, test "x$with_debug" != "xno")
# Force static compilation to avoid linking problems/get more speed
AC_ARG_WITH(mysqld-ldflags,