summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <brian@zim.(none)>2006-08-18 21:19:19 -0700
committerunknown <brian@zim.(none)>2006-08-18 21:19:19 -0700
commitb470b3ab87743a13470098b8446da3fe2e100c9e (patch)
tree5e3642a4d6fe9f0bfc4b88394c8d2dae810fb30b /configure.in
parentbc4215111ca83b8535915c8b8d207fe105b4cb66 (diff)
downloadmariadb-git-b470b3ab87743a13470098b8446da3fe2e100c9e.tar.gz
Major changes are plug.in files created for almost all storage engines. A few stray BDB references removed.
storage/blackhole/plug.in: BitKeeper file /home/brian/mysql/arch-5.1/storage/blackhole/plug.in storage/heap/plug.in: BitKeeper file /home/brian/mysql/arch-5.1/storage/heap/plug.in storage/myisam/plug.in: BitKeeper file /home/brian/mysql/arch-5.1/storage/myisam/plug.in storage/myisammrg/plug.in: BitKeeper file /home/brian/mysql/arch-5.1/storage/myisammrg/plug.in storage/federated/ha_federated.h: Rename: sql/ha_federated.h -> storage/federated/ha_federated.h BUILD/FINISH.sh: Stray BDB reference BUILD/autorun.sh: Stray bdb reference BUILD/compile-alpha-cxx: Stray bdb reference BUILD/compile-alpha-debug: Stray bdb reference BUILD/compile-dist: Stray BDB Reference BUILD/compile-ia64-debug-max: Stray BDB reference configure.in: All plugin code is now in plug.in files. Few tricky exceptions left. sql/CMakeLists.txt: Removed federated references sql/Makefile.am: Removed federated references sql/mysql_priv.h: stray bdb reference storage/example/ha_example.cc: Enabled all of mysql include storage/federated/ha_federated.cc: Added plugin defs storage/csv/plug.in: New BitKeeper file ``storage/csv/plug.in'' storage/federated/Makefile.am: New BitKeeper file ``storage/federated/Makefile.am'' storage/federated/plug.in: New BitKeeper file ``storage/federated/plug.in'' storage/innobase/plug.in: New BitKeeper file ``storage/innobase/plug.in'' storage/ndb/plug.in: New BitKeeper file ``storage/ndb/plug.in''
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in50
1 files changed, 0 insertions, 50 deletions
diff --git a/configure.in b/configure.in
index 4b1141006b5..46d27beade3 100644
--- a/configure.in
+++ b/configure.in
@@ -2140,65 +2140,15 @@ MYSQL_CHECK_SSL
# Has to be done late, as the plugin may need to check for existence of
# functions tested above
#--------------------------------------------------------------------
-
-MYSQL_STORAGE_ENGINE(blackhole,,[Blackhole Storage Engine],
- [Basic Write-only Read-never tables], [max,max-no-ndb])
-MYSQL_PLUGIN_DIRECTORY(blackhole, [storage/blackhole])
-MYSQL_PLUGIN_STATIC(blackhole, [libblackhole.a])
-MYSQL_PLUGIN_DYNAMIC(blackhole, [ha_blackhole.la])
-
-MYSQL_STORAGE_ENGINE(csv,, [CSV Storage Engine],
- [Stores tables in text CSV format])
-MYSQL_PLUGIN_DIRECTORY(csv, [storage/csv])
-MYSQL_PLUGIN_STATIC(csv, [libcsv.a])
-MYSQL_PLUGIN_MANDATORY(csv) dnl Used for logging
-
-MYSQL_STORAGE_ENGINE(federated,,[Federated Storage Engine],
- [Connects to tables on remote MySQL servers], [max,max-no-ndb])
-
MYSQL_PLUGIN(ftexample, [Simple Parser],
[Simple full-text parser plugin])
MYSQL_PLUGIN_DIRECTORY(ftexample, [plugin/fulltext])
MYSQL_PLUGIN_DYNAMIC(ftexample, [mypluglib.la])
-MYSQL_STORAGE_ENGINE(heap,no, [Memory Storage Engine],
- [Volatile memory based tables])
-MYSQL_PLUGIN_DIRECTORY(heap, [storage/heap])
-MYSQL_PLUGIN_STATIC(heap, [libheap.a])
-MYSQL_PLUGIN_MANDATORY(heap) dnl Memory tables
-
-MYSQL_STORAGE_ENGINE(innobase, innodb, [InnoDB Storage Engine],
- [Transactional Tables using InnoDB], [max,max-no-ndb])
-MYSQL_PLUGIN_DIRECTORY(innobase, [storage/innobase])
-MYSQL_PLUGIN_STATIC(innobase, [libinnobase.a])
-MYSQL_PLUGIN_ACTIONS(innobase, [
- AC_CHECK_LIB(rt, aio_read, [innodb_system_libs="-lrt"])
- AC_SUBST(innodb_system_libs)
-])
-
-MYSQL_STORAGE_ENGINE(myisam,no, [MyISAM Storage Engine],
- [Traditional non-transactional MySQL tables])
-MYSQL_PLUGIN_DIRECTORY(myisam, [storage/myisam])
-MYSQL_PLUGIN_STATIC(myisam, [libmyisam.a])
-MYSQL_PLUGIN_MANDATORY(myisam) dnl Default
-
-MYSQL_STORAGE_ENGINE(myisammrg,no,[MyISAM MERGE Engine],
- [Merge multiple MySQL tables into one])
-MYSQL_PLUGIN_DIRECTORY(myisammrg,[storage/myisammrg])
-MYSQL_PLUGIN_STATIC(myisammrg, [libmyisammrg.a])
-MYSQL_PLUGIN_MANDATORY(myisammrg)
-
-MYSQL_STORAGE_ENGINE(ndbcluster, ndbcluster, [Cluster Storage Engine],
- [High Availability Clustered tables], [max])
-MYSQL_PLUGIN_DIRECTORY(ndbcluster,[storage/ndb])
-MYSQL_PLUGIN_STATIC(ndbcluster, [[\$(ndbcluster_libs) \$(ndbcluster_system_libs) \$(NDB_SCI_LIBS)]])
-MYSQL_PLUGIN_ACTIONS(ndbcluster,[MYSQL_SETUP_NDBCLUSTER])
-
MYSQL_STORAGE_ENGINE(partition, partition, [Partition Support],
[MySQL Partitioning Support], [max,max-no-ndb])
dnl -- ndbcluster requires partition to be enabled
-MYSQL_PLUGIN_DEPENDS(ndbcluster, [partition])
MYSQL_CONFIGURE_PLUGINS([none])