summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <serg@serg.mylan>2006-04-12 14:08:24 +0200
committerunknown <serg@serg.mylan>2006-04-12 14:08:24 +0200
commitc566f9a25f53ea88ef75d2f4d6e8c6f61745b3e7 (patch)
tree46aa796924bcff90935d9149ffb0d65ac7c6ae61 /configure.in
parentef1ec197449dbfc00f64834af4564021368ac765 (diff)
downloadmariadb-git-c566f9a25f53ea88ef75d2f4d6e8c6f61745b3e7.tar.gz
fixes for 'make dist' and 'make distcheck'
BUILD/compile-dist: fixes for 'make dist' and 'make distcheck' include yassl in "dist" Makefile.am: fixes for 'make dist' and 'make distcheck' remove double-listing of everything in SUBDIRS and DIST_SUBDIRS remove @yassl_dir@, it belongs to extra/Makefile.am specify --basedir for mysql_install_db, in case builddir (where mysql_install_db is) differs from srcdir (where mysql_fix_privilege_tables.sql is) config/ac-macros/yassl.m4: fixes for 'make dist' and 'make distcheck' create Makefile's only if yassl is used yassl_dir must not include / config/ac-macros/zlib.m4: fixes for 'make dist' and 'make distcheck' create Makefile only if zlib is used configure.in: fixes for 'make dist' and 'make distcheck' create Makefile only if a feature is enabled storage engine dirs must not include / automatically disable readline/libedit/sql-bench if source dir is missing extra/Makefile.am: fixes for 'make dist' and 'make distcheck' remove SUBDIR/DIST_SUBDIR hack libmysql_r/Makefile.am: fixes for 'make dist' and 'make distcheck' when symlinking all files from libmysql/ take into account that srcdir != builddir libmysqld/Makefile.am: fixes for 'make dist' and 'make distcheck' remove fragile promiscuous search for object files if .o file is not where we look for it - extract it from the library mysql-test/ndb/Makefile.am: fixes for 'make dist' and 'make distcheck' ndbcluster script is not a "source" don't forget to cleanup plugin/Makefile.am: fixes for 'make dist' and 'make distcheck' include plugin/fulltext/configure.in template in the distribution storage/Makefile.am: fixes for 'make dist' and 'make distcheck' remove SUBDIRS/DIST_SUBDIRS hack storage/ndb/Makefile.am: fixes for 'make dist' and 'make distcheck' force common.mk.am out of DIST_COMMON (which is otherwise an auto-generated list of Makefile's sources) because it's listed indirectly in EXTRA_DIST, and with bk -r get, a file cannot be copied twice.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in39
1 files changed, 27 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 250d7f6d1c2..ddc771b3ca4 100644
--- a/configure.in
+++ b/configure.in
@@ -2304,16 +2304,20 @@ fi
AC_SUBST(man_dirs)
AC_SUBST(man1_files)
+if test -e sql-bench
+then
# Shall we build the bench code?
AC_ARG_WITH(bench,
[ --without-bench Skip building of the benchmark suite.],
[with_bench=$withval],
[with_bench=yes]
)
+fi
if test "$with_bench" = "yes"
then
bench_dirs="sql-bench"
+ AC_CONFIG_FILES(sql-bench/Makefile)
else
bench_dirs=""
fi
@@ -2332,6 +2336,11 @@ AC_ARG_WITH(libedit,
[ with_libedit=$withval ],
[ with_libedit=undefined ]
)
+if test -z "$with_readline$with_libedit" -a ! -e cmd-line-utils
+then
+ with_readline=no
+ with_libedit=no
+fi
#
# We support next variants of compilation:
@@ -2408,6 +2417,16 @@ else
versions of libedit or readline])
fi
fi
+#
+# if either readline or libedit is enabled - generate Makefile's for both
+# (to make sure both are included in 'make dist')
+#
+if test -n "$readline_basedir"
+then
+ AC_CONFIG_FILES(cmd-line-utils/Makefile dnl
+ cmd-line-utils/libedit/Makefile dnl
+ cmd-line-utils/readline/Makefile)
+fi
fi
AC_SUBST(readline_dir)
@@ -2420,7 +2439,7 @@ MYSQL_CHECK_BIG_TABLES
MYSQL_CHECK_MAX_INDEXES
MYSQL_CHECK_REPLICATION
-MYSQL_STORAGE_ENGINE(innobase,,innodb,,,,storage/innobase,ha_innodb.o,[ dnl
+MYSQL_STORAGE_ENGINE(innobase,,innodb,,,,innobase,ha_innodb.o,[ dnl
\$(top_builddir)/storage/innobase/usr/libusr.a dnl
\$(top_builddir)/storage/innobase/srv/libsrv.a dnl
\$(top_builddir)/storage/innobase/dict/libdict.a dnl
@@ -2462,24 +2481,24 @@ MYSQL_STORAGE_ENGINE(innobase,,innodb,,,,storage/innobase,ha_innodb.o,[ dnl
other_configures="$other_configures storage/innobase/configure"
])
-MYSQL_STORAGE_ENGINE(berkeley,,berkeley-db,,,,storage/bdb,,,[
+MYSQL_STORAGE_ENGINE(berkeley,,berkeley-db,,,,bdb,,,[
MYSQL_SETUP_BERKELEY_DB
])
-MYSQL_STORAGE_ENGINE(example,,,,,,storage/example,no,
+MYSQL_STORAGE_ENGINE(example,,,,,,example,no,
\$(top_builddir)/storage/example/libexample.a,[
AC_CONFIG_FILES(storage/example/Makefile)
])
-MYSQL_STORAGE_ENGINE(archive,,,,,,storage/archive,,
+MYSQL_STORAGE_ENGINE(archive,,,,,,archive,,
\$(top_builddir)/storage/archive/libarchive.a, [
AC_CONFIG_FILES(storage/archive/Makefile)
])
-MYSQL_STORAGE_ENGINE(csv,,,"yes",,tina_hton,storage/csv,no,
+MYSQL_STORAGE_ENGINE(csv,,,"yes",,tina_hton,csv,no,
\$(top_builddir)/storage/csv/libcsv.a,[
AC_CONFIG_FILES(storage/csv/Makefile)
])
MYSQL_STORAGE_ENGINE(blackhole)
MYSQL_STORAGE_ENGINE(federated)
-MYSQL_STORAGE_ENGINE(ndbcluster,,ndbcluster,,,,storage/ndb,,,[
+MYSQL_STORAGE_ENGINE(ndbcluster,,ndbcluster,,,,ndb,,,[
MYSQL_SETUP_NDBCLUSTER
])
MYSQL_STORAGE_ENGINE(partition,,partition)
@@ -2539,7 +2558,7 @@ then
AC_SUBST(THREAD_LOBJECTS)
server_scripts="mysqld_safe mysql_install_db"
sql_server_dirs="strings mysys dbug extra regex"
- mysql_se_dirs="storage/myisam storage/myisammrg storage/heap $mysql_se_dirs"
+ mysql_se_dirs="myisam myisammrg heap $mysql_se_dirs"
sql_server="$sql_server vio sql"
fi
@@ -2610,16 +2629,12 @@ AC_CONFIG_FILES(Makefile extra/Makefile mysys/Makefile dnl
pstack/Makefile pstack/aout/Makefile sql/Makefile sql/share/Makefile dnl
sql/handlerton.cc sql-common/Makefile SSL/Makefile dnl
dbug/Makefile scripts/Makefile dnl
- include/Makefile sql-bench/Makefile dnl
+ include/Makefile dnl
server-tools/Makefile server-tools/instance-manager/Makefile dnl
tests/Makefile Docs/Makefile support-files/Makefile dnl
support-files/MacOSX/Makefile mysql-test/Makefile dnl
mysql-test/ndb/Makefile netware/Makefile dnl
include/mysql_version.h dnl
- cmd-line-utils/Makefile dnl
- cmd-line-utils/libedit/Makefile dnl
- zlib/Makefile dnl
- cmd-line-utils/readline/Makefile dnl
plugin/Makefile dnl
plugin/fulltext/Makefile dnl
win/Makefile)