summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@mysql.com>2004-06-01 23:34:47 +0300
committerunknown <monty@mysql.com>2004-06-01 23:34:47 +0300
commit010fffc2f7568e219018706918e08e7310b38fcd (patch)
treefafbfed6426759740e614660278a12f746391d58 /configure.in
parentfec8faa06a4f9b167e3cad9ac31cdf05bc4025e0 (diff)
downloadmariadb-git-010fffc2f7568e219018706918e08e7310b38fcd.tar.gz
Updated version number
Portability fix for netware. (We can't use TRY_RUN when cross compiling)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index f2b66d1e09d..e346ebfa15e 100644
--- a/configure.in
+++ b/configure.in
@@ -4,7 +4,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(sql/mysqld.cc)
AC_CANONICAL_SYSTEM
# The Docs Makefile.am parses this line!
-AM_INIT_AUTOMAKE(mysql, 4.0.20)
+AM_INIT_AUTOMAKE(mysql, 4.0.21)
AM_CONFIG_HEADER(config.h)
PROTOCOL_VERSION=10
@@ -767,7 +767,14 @@ AC_CHECK_FUNC(crypt, AC_DEFINE(HAVE_CRYPT))
AC_CHECK_FUNC(sem_init, , AC_CHECK_LIB(posix4, sem_init))
# For compress in zlib
-MYSQL_CHECK_ZLIB_WITH_COMPRESS($with_named_zlib)
+case $SYSTEM_TYPE in
+ *netware*)
+ AC_DEFINE(HAVE_COMPRESS)
+ ;;
+ *)
+ MYSQL_CHECK_ZLIB_WITH_COMPRESS($with_named_zlib)
+ ;;
+esac
#--------------------------------------------------------------------
# Check for TCP wrapper support