summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <mikron@c-4d08e253.1238-1-64736c10.cust.bredbandsbolaget.se>2006-02-01 10:06:07 +0100
committerunknown <mikron@c-4d08e253.1238-1-64736c10.cust.bredbandsbolaget.se>2006-02-01 10:06:07 +0100
commit520dffb5204a471030c3e43494cd3419136bce05 (patch)
treeee595d281d0c24ddb01956f2536edd9b4c49ea04 /configure.in
parent3a2b70f8414a1ee02f8a210f22a2707f66bf0ce5 (diff)
downloadmariadb-git-520dffb5204a471030c3e43494cd3419136bce05.tar.gz
WL 2826: First step in error handling of ALTER TABLE for partitioning
BUILD/SETUP.sh: Add possibility for BUILD scripts to add error inject flag BUILD/compile-pentium-debug-max: Add error inject flag to this script configure.in: Add handling of --with-error-inject in configure script sql/ha_ndbcluster.cc: Add possibility to rename handler file sql/ha_ndbcluster.h: Add possibility to rename handler file sql/ha_partition.cc: Add possibility to rename handler file sql/ha_partition.h: Add possibility to rename handler file sql/handler.h: Add possibility to rename handler file sql/mysql_priv.h: Add error inject macros sql/mysqld.cc: Add error inject system variables sql/set_var.cc: Add error inject system variables sql/sql_class.h: Add error inject system variables sql/sql_table.cc: Start modifying code for introducing table log, Step 1 sql/unireg.cc: Add rename flag to handler file call sql/sql_partition.cc: Changes to ADD/DROP/CHANGE partitions
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ffc311a7857..ad69365a1b9 100644
--- a/configure.in
+++ b/configure.in
@@ -654,6 +654,7 @@ else
AC_MSG_RESULT([no])
fi
+
MYSQL_SYS_LARGEFILE
# Types that must be checked AFTER large file support is checked
@@ -1554,6 +1555,18 @@ then
DEBUG_OPTIMIZE_CXX=""
fi
+# If we should allow error injection tests
+AC_ARG_WITH(error-inject,
+ [ --with-error-inject Enable error injection in MySQL Server],
+ [ with_error_inject=$withval ],
+ [ with_error_inject=no ])
+
+if test "$with_error_inject" = "yes"
+then
+ CFLAGS="-DERROR_INJECT_SUPPORT $CFLAGS"
+ CXXFLAGS="-DERROR_INJECT_SUPPORT $CXXFLAGS"
+fi
+
AC_ARG_WITH(debug,
[ --without-debug Build a production version without debugging code],
[with_debug=$withval],