summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexey Kopytov <Alexey.Kopytov@sun.com>2009-03-25 16:19:53 +0300
committerAlexey Kopytov <Alexey.Kopytov@sun.com>2009-03-25 16:19:53 +0300
commit4ee0f6a64c89f226a113688ab6f894f9e18ffa74 (patch)
treef492a6c519a23459220c8e3df6f7896662ce82a3 /configure.in
parent77cc537e0d51aa206eb37e38beb821a716aff576 (diff)
parentbbe24f03f2288049b39359ad52b0cccc1b762b44 (diff)
downloadmariadb-git-4ee0f6a64c89f226a113688ab6f894f9e18ffa74.tar.gz
Automerge.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ed252d4fc46..9fdb1930cde 100644
--- a/configure.in
+++ b/configure.in
@@ -2094,6 +2094,27 @@ esac
AC_MSG_CHECKING(for isinf in <math.h>)
AC_TRY_LINK([#include <math.h>], [float f = 0.0; int r = isinf(f); return r],
AC_MSG_RESULT(yes)
+ AC_MSG_CHECKING(whether isinf() is safe to use in C code)
+ AC_TRY_RUN([
+#include <math.h>
+int main()
+{
+ double a= 10.0;
+ double b= 1e308;
+
+ return !isinf(a * b);
+}
+],
+ [AC_MSG_RESULT(yes)],
+ [AC_MSG_RESULT(no)
+ AC_DEFINE([HAVE_BROKEN_ISINF], [1],
+ [Define to 1 if isinf() uses 80-bit register for intermediate values])
+ ],
+ [
+# Let's be optimistic when cross-compiling, since the only compiler known
+# to be affected by this isinf() bug is GCC 4.3 on 32-bit x86.
+ AC_MSG_RESULT([[cross-compiling, assuming 'yes']])
+ ])
AC_MSG_CHECKING(whether isinf() can be used in C++ code)
AC_LANG_SAVE
AC_LANG_CPLUSPLUS