summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <konstantin@mysql.com>2006-01-18 15:15:09 +0300
committerunknown <konstantin@mysql.com>2006-01-18 15:15:09 +0300
commitf9bef505ece36b992c17d38c2c6714504d66d1b3 (patch)
tree615bbf8a236ace6dcc24da1dee532712f102f681 /configure.in
parent596666f74a83e989edb712eab9949d2a13c08fac (diff)
parent22bc685dbf3769e4df9aedf139635c8b85bdeb37 (diff)
downloadmariadb-git-f9bef505ece36b992c17d38c2c6714504d66d1b3.tar.gz
Merge mysql.com:/opt/local/work/mysql-4.1-root
into mysql.com:/opt/local/work/mysql-5.0-root BitKeeper/etc/ignore: auto-union libmysql/Makefile.shared: Auto merged configure.in: Manual merge. libmysql/libmysql.c: Manual merge. tests/mysql_client_test.c: Manual merge.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b5c31361b26..c171badb8e7 100644
--- a/configure.in
+++ b/configure.in
@@ -13,7 +13,8 @@ AM_CONFIG_HEADER(config.h)
PROTOCOL_VERSION=10
DOT_FRM_VERSION=6
# See the libtool docs for information on how to do shared lib versions.
-SHARED_LIB_VERSION=15:0:0
+SHARED_LIB_MAJOR_VERSION=15
+SHARED_LIB_VERSION=$SHARED_LIB_MAJOR_VERSION:0:0
# ndb version
NDB_VERSION_MAJOR=5
@@ -69,6 +70,7 @@ AC_DEFINE_UNQUOTED([PROTOCOL_VERSION], [$PROTOCOL_VERSION],
AC_SUBST(DOT_FRM_VERSION)
AC_DEFINE_UNQUOTED([DOT_FRM_VERSION], [$DOT_FRM_VERSION],
[Version of .frm files])
+AC_SUBST(SHARED_LIB_MAJOR_VERSION)
AC_SUBST(SHARED_LIB_VERSION)
AC_SUBST(AVAILABLE_LANGUAGES)
@@ -361,6 +363,13 @@ fi
MYSQL_PROG_AR
+# libmysqlclient versioning when linked with GNU ld.
+if $LD --version 2>/dev/null|grep -q GNU; then
+ LD_VERSION_SCRIPT="-Wl,--version-script=\$(top_srcdir)/libmysql/libmysql.ver"
+ AC_CONFIG_FILES(libmysql/libmysql.ver)
+fi
+AC_SUBST(LD_VERSION_SCRIPT)
+
# Avoid bug in fcntl on some versions of linux
AC_MSG_CHECKING("if we should use 'skip-locking' as default for $target_os")
# Any variation of Linux