summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tsmith@siva.hindu.god>2007-01-11 13:50:48 -0700
committerunknown <tsmith@siva.hindu.god>2007-01-11 13:50:48 -0700
commit44318bbbddf0eec0f7b4b0fc9d11678750600f7c (patch)
treed5ad489509eb68843615a2f7425506f6d90d1fef /configure.in
parente64f4fdebb11a60bed4d8e367d9c99ab50e6e89d (diff)
parenta4817aced500feede54a9548b650650e513b69d9 (diff)
downloadmariadb-git-44318bbbddf0eec0f7b4b0fc9d11678750600f7c.tar.gz
Merge siva.hindu.god:/home/tsmith/m/bk/mysql-5.0-build
into siva.hindu.god:/home/tsmith/m/bk/mysql-5.1-build BitKeeper/deleted/.del-CMakeLists.txt~3: Auto merged BitKeeper/deleted/.del-README~1: Auto merged BitKeeper/deleted/.del-configure.js: Auto merged BitKeeper/deleted/.del-mysql_test_run_new.c~a23ab2c4b28b25ad: Auto merged mysql-test/mysql-test-run.pl: Auto merged scripts/mysql_install_db.sh: Auto merged configure.in: Manual merge mysql-test/install_test_db.sh: Manual merge sql/mysqld.cc: Manual merge
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 60c41689057..2a238a1f221 100644
--- a/configure.in
+++ b/configure.in
@@ -678,7 +678,22 @@ else
AC_MSG_RESULT([no])
fi
-
+# If we should allow init-file, skip-grant-table and bootstrap options
+AC_MSG_CHECKING(If we should should enable init-file, skip-grant-table options and bootstrap)
+AC_ARG_ENABLE(grant-options,
+ [ --disable-grant-options Disables the use of --init-file, --skip-grant-tables and --bootstrap options],
+ [ mysql_grant_options_enabled=$enableval ],
+ [ mysql_grant_options_enabled=yes ]
+ )
+if test "$mysql_grant_options_enabled" = "yes"
+then
+ AC_MSG_RESULT([yes])
+else
+ AC_DEFINE([DISABLE_GRANT_OPTIONS], [1],
+ [Disables the use of --init-file, --skip-grant-tables and --bootstrap options])
+ AC_MSG_RESULT([no])
+fi
+
MYSQL_SYS_LARGEFILE
# Types that must be checked AFTER large file support is checked