summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorcmiller@zippy.(none) <>2006-07-12 11:39:12 -0400
committercmiller@zippy.(none) <>2006-07-12 11:39:12 -0400
commit4980c64a5b5f76601a891ef32b76a22a9dbd8db0 (patch)
tree04a65eb3a0f36e8e8318430e08af963e489249d6 /configure.in
parente62e7300202f8bfc6adbc9046be32363da66e48b (diff)
parent834111811b5190733dcd26336a4ae6fe83bb2ba4 (diff)
downloadmariadb-git-4980c64a5b5f76601a891ef32b76a22a9dbd8db0.tar.gz
Merge zippy.(none):/home/cmiller/mysql-4.1_bug18470
into zippy.(none):/home/cmiller/work/mysql/m50-maint--07C2P
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 48454a11309..be9ac7b4491 100644
--- a/configure.in
+++ b/configure.in
@@ -651,7 +651,7 @@ AC_ARG_ENABLE(assembler,
AC_MSG_CHECKING(if we should use assembler functions)
# For now we only support assembler on i386 and sparc systems
-AM_CONDITIONAL(ASSEMBLER_x86, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "i386")
+AM_CONDITIONAL(ASSEMBLER_x86, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "i386" && $AS strings/strings-x86.s -o checkassembler >/dev/null 2>&1 && test -f checkassembler && (rm -f checkassembler; exit 0;))
AM_CONDITIONAL(ASSEMBLER_sparc32, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "sparc")
AM_CONDITIONAL(ASSEMBLER_sparc64, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "sparcv9")
AM_CONDITIONAL(ASSEMBLER, test "$ASSEMBLER_x86_TRUE" = "" -o "$ASSEMBLER_sparc32_TRUE" = "")