summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoriggy@mysql.com <>2006-06-27 18:07:23 -0400
committeriggy@mysql.com <>2006-06-27 18:07:23 -0400
commit578fee6990e57877147c5a35ea70714630cbe5cf (patch)
tree6ff3581e44c7cf8e4206291be7c3f437a3937ccc /configure.in
parent748b287cad28c0ef9fad5d4b1076ece9c01c61cc (diff)
downloadmariadb-git-578fee6990e57877147c5a35ea70714630cbe5cf.tar.gz
Bug#19298 mysqld_safe still uses obsolete --skip-locking parameter
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 7eadc5bd241..773ab7630bd 100644
--- a/configure.in
+++ b/configure.in
@@ -441,18 +441,18 @@ fi
AC_SUBST(LD_VERSION_SCRIPT)
# Avoid bug in fcntl on some versions of linux
-AC_MSG_CHECKING("if we should use 'skip-locking' as default for $target_os")
+AC_MSG_CHECKING([if we should use 'skip-external-locking' as default for $target_os])
# Any wariation of Linux
if expr "$target_os" : "[[Ll]]inux.*" > /dev/null
then
- MYSQLD_DEFAULT_SWITCHES="--skip-locking"
+ MYSQLD_DEFAULT_SWITCHES="--skip-external-locking"
TARGET_LINUX="true"
- AC_MSG_RESULT("yes")
+ AC_MSG_RESULT([yes])
AC_DEFINE([TARGET_OS_LINUX], [1], [Whether we build for Linux])
else
MYSQLD_DEFAULT_SWITCHES=""
TARGET_LINUX="false"
- AC_MSG_RESULT("no")
+ AC_MSG_RESULT([no])
fi
AC_SUBST(MYSQLD_DEFAULT_SWITCHES)
AC_SUBST(TARGET_LINUX)