summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavi Arnaut <davi.arnaut@oracle.com>2010-10-19 14:48:03 -0200
committerDavi Arnaut <davi.arnaut@oracle.com>2010-10-19 14:48:03 -0200
commit7406b38efa0a2eec5a245839c5ce13b85d51d125 (patch)
treedc5cb87c2c3e11ad363dfd393b561d2a76b561a1 /configure.in
parentbe170c213fa285acfb79e06ba249a9bb30155275 (diff)
downloadmariadb-git-7406b38efa0a2eec5a245839c5ce13b85d51d125.tar.gz
Bug#45288: pb2 returns a lot of compilation warnings
Ensure that fdatasync is properly declared as on Mac OS X, the function is available but there is no prototype. Also, port a fix for a warning from the InnoDB plugin over to the builtin. configure.in: Check that fdatasync is declared. mysys/my_sync.c: Use fdatasync only if it is declared. storage/innobase/include/ut0dbg.h: Port over from the plugin a fix for a warning.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 09885dbbae7..4ea978c268e 100644
--- a/configure.in
+++ b/configure.in
@@ -2073,6 +2073,13 @@ MYSQL_TYPE_QSORT
AC_FUNC_UTIME_NULL
AC_FUNC_VPRINTF
+AC_CHECK_DECLS([fdatasync],,,
+[
+#ifdef HAVE_UNISTD_H
+# include <unistd.h>
+#endif
+])
+
AC_CHECK_FUNCS(alarm bfill bmove bsearch bzero \
chsize cuserid fchmod fcntl \
fconvert fdatasync fesetround finite fpresetsticky fpsetmask fsync ftruncate \