summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChristoffer Hall <hall@mysql.com>2009-06-22 14:43:19 +0200
committerChristoffer Hall <hall@mysql.com>2009-06-22 14:43:19 +0200
commit77fb9608a975ada6ec44d7dfb875967ecdac06a6 (patch)
tree584b9dd9432d9c5c0cb3f8e853d4ffd80d22797f /configure.in
parentcf66632d5eefc4e0bd0b58ca2c2ef31bb7811e14 (diff)
downloadmariadb-git-77fb9608a975ada6ec44d7dfb875967ecdac06a6.tar.gz
BUG#42721 configure.in invokes 'nm' directly
A hardcoded use of nm and libc was put into configure.in. This broke cross-compiling and is bad practice. Fitting variables now used.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index bd26e584bfe..33ac021ec76 100644
--- a/configure.in
+++ b/configure.in
@@ -603,10 +603,11 @@ AC_SUBST(NOINST_LDFLAGS)
# Check if we are using Linux and a glibc compiled with static nss
# (this is true on the MySQL build machines to avoid NSS problems)
#
+AC_CHECK_TOOL([NM], [nm])
if test "$TARGET_LINUX" = "true" -a "$static_nss" = ""
then
- tmp=`nm /usr/lib*/libc.a | grep _nss_files_getaliasent_r`
+ tmp=`$NM ${other_libc_lib:-/usr/lib*}/libc.a | grep _nss_files_getaliasent_r1`
if test -n "$tmp"
then
STATIC_NSS_FLAGS="-lc -lnss_files -lnss_dns -lresolv"