summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <bell@sanja.is.com.ua>2006-04-13 15:07:50 +0300
committerunknown <bell@sanja.is.com.ua>2006-04-13 15:07:50 +0300
commit1cc27df05df05061f0cc240ab6fec36c83f81839 (patch)
treed096b4ad76ab8747e5598eb10f6c70cc55978bd0 /configure.in
parent93409ee7bebcf8df98ab532884ecfdaaae1f96cc (diff)
parentc2ee905473ca0b380c3b952a27691f3411592b8c (diff)
downloadmariadb-git-1cc27df05df05061f0cc240ab6fec36c83f81839.tar.gz
Merge sanja.is.com.ua:/home/bell/mysql/bk/mysql-4.1
into sanja.is.com.ua:/home/bell/mysql/bk/work-5.0 BitKeeper/deleted/.del-acinclude.m4~f4ab416bac5003: Auto merged configure.in: Auto merged mysql-test/r/func_op.result: Auto merged sql/item_func.cc: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3e936ae422f..174c9a16d8e 100644
--- a/configure.in
+++ b/configure.in
@@ -805,6 +805,9 @@ AC_SUBST(WRAPLIBS)
if test "$TARGET_LINUX" = "true"; then
AC_MSG_CHECKING([for atomic operations])
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+
atom_ops=
AC_TRY_RUN([
#include <asm/atomic.h>
@@ -840,6 +843,8 @@ int main()
if test -z "$atom_ops"; then atom_ops="no"; fi
AC_MSG_RESULT($atom_ops)
+ AC_LANG_RESTORE
+
AC_ARG_WITH(pstack,
[ --with-pstack Use the pstack backtrace library],
[ USE_PSTACK=$withval ],