summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2006-03-10 09:51:08 +0100
committerunknown <msvensson@neptunus.(none)>2006-03-10 09:51:08 +0100
commit81858c0efa0079ff1320ba097f32a3c6657ddcef (patch)
treef9803f37ff106081109e37505805270aac596876 /configure.in
parenta7abbd918ba952e2f387cec28ed0f74997b14975 (diff)
downloadmariadb-git-81858c0efa0079ff1320ba097f32a3c6657ddcef.tar.gz
Bug#11835 CREATE FUNCTION crashes server
- Don't look for 'dl_open' if mysqld is compiled with "-all-static" configure.in: No need to check for dlopen when mysqld is linked with -all-static as it won't be able to load any functions (and in some cases segfaults)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in42
1 files changed, 28 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index b230b7f042e..9749833f635 100644
--- a/configure.in
+++ b/configure.in
@@ -1632,16 +1632,35 @@ else
fi
#---END:
-# Check for dlopen, needed for user definable functions
-# This must be checked after threads on AIX
-# We only need this for mysqld, not for the clients.
+# dlopen, dlerror
+case $with_mysqld_ldflags in
+
+ *-all-static*)
+ # No need to check for dlopen when mysqld is linked with
+ # -all-static as it won't be able to load any functions.
+
+ ;;
+
+ *)
+ # Check for dlopen, needed for user definable functions
+ # This must be checked after threads on AIX
+ # We only need this for mysqld, not for the clients.
+
+ my_save_LIBS="$LIBS"
+ LIBS=""
+ AC_CHECK_LIB(dl,dlopen)
+ LIBDL=$LIBS
+ LIBS="$my_save_LIBS"
+ AC_SUBST(LIBDL)
+
+ my_save_LIBS="$LIBS"
+ LIBS="$LIBS $LIBDL"
+ AC_CHECK_FUNCS(dlopen dlerror)
+ LIBS="$my_save_LIBS"
+
+ ;;
+esac
-my_save_LIBS="$LIBS"
-LIBS=""
-AC_CHECK_LIB(dl,dlopen)
-LIBDL=$LIBS
-LIBS="$my_save_LIBS"
-AC_SUBST(LIBDL)
# System characteristics
case $SYSTEM_TYPE in
@@ -2005,11 +2024,6 @@ then
fi]
)
-my_save_LIBS="$LIBS"
-LIBS="$LIBS $LIBDL"
-AC_CHECK_FUNCS(dlopen dlerror)
-LIBS="$my_save_LIBS"
-
# Check definition of gethostbyaddr_r (glibc2 defines this with 8 arguments)
ac_save_CXXFLAGS="$CXXFLAGS"
AC_CACHE_CHECK([style of gethost* routines], mysql_cv_gethost_style,