summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <joerg@mysql.com>2004-12-30 14:03:19 +0100
committerunknown <joerg@mysql.com>2004-12-30 14:03:19 +0100
commitf116ac5cdd84cf7e85aa9803e31e9d506c906f95 (patch)
treeffb1778d170b1aaab1eec0035964526f51982c69 /configure.in
parent05fb4757f984607737999b86dc052b5c91bf5bd8 (diff)
downloadmariadb-git-f116ac5cdd84cf7e85aa9803e31e9d506c906f95.tar.gz
Clean up the handling of "server" and "client" directories, while still avoiding the double listing of
common directories in 'SUBDIRS' macro ("make distclean" had failed due to that). Solves bug#7368: "regex make error in 4.1.8" BitKeeper/etc/ignore: Added ndb/include/ndb_version.h ndb/include/ndb_global.h to the ignore list Makefile.am: Build the 'SUBDIRS' list from the new variable 'sql_union_dirs', not the old "client" and "servers" lists which will overlap. That overlap worked for build runs, but it caused failures of 'make distclean' etc because the overlapping directories were cleaned twice which could not work. Solves bug#7368: "regex make error in 4.1.8" configure.in: Introduce a new variable 'sql_union_dirs' to contain those directories which are needed for either server or client. This is needed to have complete "server" and "client" directory lists in 'Makefile' but prevent double listing in 'SUBDIRS' (see the comment for 'Makefile.am'). Solves bug#7368: "regex make error in 4.1.8"
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index bc78c9c8764..ce3ae9c8dff 100644
--- a/configure.in
+++ b/configure.in
@@ -2832,7 +2832,7 @@ thread_dirs=
dnl This probably should be cleaned up more - for now the threaded
dnl client is just using plain-old libs.
-sql_client_dirs="libmysql client"
+sql_client_dirs="libmysql strings regex client"
linked_client_targets="linked_libmysql_sources"
CLIENT_LIBS=$NON_THREADED_CLIENT_LIBS
if test "$THREAD_SAFE_CLIENT" != "no"
@@ -3014,6 +3014,20 @@ AC_SUBST(sql_server_dirs)
AC_SUBST(thread_dirs)
AC_SUBST(server_scripts)
+# Now that sql_client_dirs and sql_server_dirs are stable, determine the union.
+# Start with the (longer) server list, add each client item not yet present.
+sql_union_dirs=" $sql_server_dirs "
+for DIR in $sql_client_dirs
+do
+ if echo $sql_union_dirs | grep " $DIR " >/dev/null
+ then
+ : # already present, skip
+ else
+ sql_union_dirs="$sql_union_dirs $DIR "
+ fi
+done
+AC_SUBST(sql_union_dirs)
+
#if test "$with_posix_threads" = "no" -o "$with_mit_threads" = "yes"
#then
# MIT pthreads does now support connecting with unix sockets