summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@donna.mysql.fi>2001-04-17 14:02:28 +0300
committerunknown <monty@donna.mysql.fi>2001-04-17 14:02:28 +0300
commit51c2a1ebb081a9dbe031e6c345ff216f882f1ac4 (patch)
tree2feb7d4406cc5558be41ea402576222b0ff9e4fc /configure.in
parent8512c526ab768c77f0023c9b4d75949a1727acaf (diff)
downloadmariadb-git-51c2a1ebb081a9dbe031e6c345ff216f882f1ac4.tar.gz
Fixed that -ldl is not used for clients
Fixed rpl000001 to handle the most common mysql-test-run ports. configure.in: Fixed that -ldl is not used for clients (The old version breaked when client was compiled staticly) mysql-test/r/rpl000001.result: Fix to handle the most common mysql-test-run ports. mysql-test/t/rpl000001.test: Fix to handle the most common mysql-test-run ports. mysys/my_alloc.c: Extended min block a little to get faster mallocs scripts/mysql_install_db.sh: Fixed bug when using RPM and one had --basedir in my.cnf sql/Makefile.am: Add -ldl to mysqld link line strings/ctype-ujis.c: Remove warnings
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 15 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index f0c2d30c035..6f3063ae177 100644
--- a/configure.in
+++ b/configure.in
@@ -1114,8 +1114,16 @@ else
fi
#---END:
-# for user definable functions (must be checked after threads on AIX)
+# Check for dlopen, needed for user definable functions
+# This must be checked after threads on AIX
+# We only need this for mysqld, not for the clients.
+
+my_save_LIBS="$LIBS"
+LIBS=""
AC_CHECK_LIB(dl,dlopen)
+LIBDL=$LIBS
+LIBS="$my_save_LIBS"
+AC_SUBST(LIBDL)
# System characteristics
AC_SYS_RESTARTABLE_SYSCALLS
@@ -1346,7 +1354,7 @@ AC_CHECK_FUNCS(alarm bmove \
pthread_setschedparam pthread_attr_setprio pthread_attr_setschedparam \
pthread_attr_create pthread_getsequence_np pthread_attr_setstacksize \
pthread_condattr_create rwlock_init pthread_rwlock_rdlock pthread_yield\
- dlopen dlerror fchmod getpass getpassphrase initgroups mlockall)
+ fchmod getpass getpassphrase initgroups mlockall)
# Sanity check: We chould not have any fseeko symbol unless
# large_file_support=yes
@@ -1357,6 +1365,11 @@ then
fi]
)
+my_save_LIBS="$LIBS"
+LIBS="$LIBS $LIBDL"
+AC_CHECK_FUNCS(dlopen dlerror)
+LIBS="$my_save_LIBS"
+
# Check definition of gethostbyaddr_r (glibc2 defines this with 8 arguments)
ac_save_CXXFLAGS="$CXXFLAGS"
AC_CACHE_CHECK([style of gethost* routines], mysql_cv_gethost_style,