summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormonty@tik.mysql.fi <>2001-08-04 00:10:00 +0300
committermonty@tik.mysql.fi <>2001-08-04 00:10:00 +0300
commit0d55e936143781df740f815a0e21707c1f1932e7 (patch)
treee66ed14abc4942fc09ac21472d60a38c725d4f39 /configure.in
parent493f10550a983852cfcab36e935b6e10d2d28bbd (diff)
downloadmariadb-git-0d55e936143781df740f815a0e21707c1f1932e7.tar.gz
Fix when using --without-server --with-thread-safe-client
Added prototype for my_thread_end New error message for MATCH Give error when using myisamchk --force --readonly
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index cfe6d323021..87a144b4b57 100644
--- a/configure.in
+++ b/configure.in
@@ -4,7 +4,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(sql/mysqld.cc)
AC_CANONICAL_SYSTEM
# The Docs Makefile.am parses this line!
-AM_INIT_AUTOMAKE(mysql, 3.23.40)
+AM_INIT_AUTOMAKE(mysql, 3.23.41)
AM_CONFIG_HEADER(config.h)
PROTOCOL_VERSION=10
@@ -1946,9 +1946,13 @@ AC_SUBST(CLIENT_LIBS)
AC_SUBST(sql_client_dirs)
AC_SUBST(linked_client_targets)
-if test "$with_server" = "yes"
+if test "$with_server" = "yes" -o "$THREAD_SAFE_CLIENT" != "no"
then
AC_DEFINE(THREAD)
+fi
+
+if test "$with_server" = "yes"
+then
# Avoid _PROGRAMS names
THREAD_LPROGRAMS="test_thr_alarm test_thr_lock"
AC_SUBST(THREAD_LPROGRAMS)
@@ -2044,7 +2048,10 @@ EOF
AC_DEFINE(HAVE_GEMINI_DB)
fi
+fi
+if test "$with_server" = "yes" -o "$THREAD_SAFE_CLIENT" != "no"
+then
if test "$with_posix_threads" = "no" -o "$with_mit_threads" = "yes"
then
# MIT user level threads