summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <pappa@c-9a08e253.1238-1-64736c10.cust.bredbandsbolaget.se>2006-02-20 16:41:46 -0500
committerunknown <pappa@c-9a08e253.1238-1-64736c10.cust.bredbandsbolaget.se>2006-02-20 16:41:46 -0500
commit1154609c39975dbba426224c6204e620c80dfa28 (patch)
tree533d4b4a1f19955e1d06cf6dc56822ea1c083256 /configure.in
parent613d172123a3bcf1dedfc9be84a78a5de356b37f (diff)
parent5b6c6c49b8316d6d8b2f77abafc6743c372385d7 (diff)
downloadmariadb-git-1154609c39975dbba426224c6204e620c80dfa28.tar.gz
Merge c-9a08e253.1238-1-64736c10.cust.bredbandsbolaget.se:/home/pappa/mysql-5.1-bugs
into c-9a08e253.1238-1-64736c10.cust.bredbandsbolaget.se:/home/pappa/wl2826 configure.in: Auto merged sql/ha_ndbcluster.cc: Auto merged sql/ha_ndbcluster.h: Auto merged sql/handler.h: Auto merged sql/mysql_priv.h: Auto merged sql/mysqld.cc: Auto merged sql/set_var.cc: Auto merged sql/sql_base.cc: Auto merged sql/sql_class.cc: Auto merged sql/sql_class.h: Auto merged sql/sql_partition.cc: Auto merged sql/sql_table.cc: Auto merged sql/sql_yacc.yy: Auto merged sql/table.cc: Auto merged dbug/dbug.c: Manual merge include/my_dbug.h: Manual merge sql/ha_heap.cc: Manual merge sql/ha_myisammrg.cc: Manual merge sql/ha_partition.cc: Manual merge sql/log.cc: Manual merge sql/share/errmsg.txt: Manual merge
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2f287ac2fce..65031acd3b9 100644
--- a/configure.in
+++ b/configure.in
@@ -663,6 +663,7 @@ else
AC_MSG_RESULT([no])
fi
+
MYSQL_SYS_LARGEFILE
# Types that must be checked AFTER large file support is checked
@@ -1563,6 +1564,18 @@ then
DEBUG_OPTIMIZE_CXX=""
fi
+# If we should allow error injection tests
+AC_ARG_WITH(error-inject,
+ [ --with-error-inject Enable error injection in MySQL Server],
+ [ with_error_inject=$withval ],
+ [ with_error_inject=no ])
+
+if test "$with_error_inject" = "yes"
+then
+ CFLAGS="-DERROR_INJECT_SUPPORT $CFLAGS"
+ CXXFLAGS="-DERROR_INJECT_SUPPORT $CXXFLAGS"
+fi
+
AC_ARG_WITH(debug,
[ --without-debug Build a production version without debugging code],
[with_debug=$withval],