summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortsmith@siva.hindu.god <>2007-01-09 19:22:01 -0700
committertsmith@siva.hindu.god <>2007-01-09 19:22:01 -0700
commitbac65ee90a724278b76b27da12c0728b7427324c (patch)
tree66654967ac4cd7bca3c3211426681a8f9ce3879d /configure.in
parentdbf5fe90a63424f70dcf9bf3a9f347e0588c61a5 (diff)
downloadmariadb-git-bac65ee90a724278b76b27da12c0728b7427324c.tar.gz
WL #3670: Compile-time option to remove GRANT-related startup options
- configure --disable-grant-options defines DISABLE_GRANT_OPTIONS - configure.js/cmake also updated - if DISABLE_GRANT_OPTIONS is defined, mysqld no longer recognizes: --bootstrap --init-file --skip-grant-tables Scripts which rely on those three options are modified to check the environment for MYSQLD_BOOTSTRAP; it should be set to the full path of a mysqld which does handle those options. For example: $ export MYSQLD_BOOTSTRAP $ MYSQLD_BOOTSTRAP=/path/to/full/MySQL/bin/mysqld $ mysql_install_db $ make test
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f6a6eedac70..19fe70c0c4d 100644
--- a/configure.in
+++ b/configure.in
@@ -713,6 +713,22 @@ else
AC_MSG_RESULT([no])
fi
+# If we should allow init-file and skip-grant-table options
+AC_MSG_CHECKING(If we should should enable init-file and skip-grant-table options)
+AC_ARG_ENABLE(grant-options,
+ [ --disable-grant-options Disables the use of --init-file and --skip-grant-tables options],
+ [ mysql_grant_options_enabled=$enableval ],
+ [ mysql_grant_options_enabled=no ]
+ )
+if test "$mysql_grant_options_enabled" = "yes"
+then
+ AC_MSG_RESULT([yes])
+else
+ AC_DEFINE([DISABLE_GRANT_OPTIONS], [1],
+ [Disables the use of --init-file and --skip-grant-tables options])
+ AC_MSG_RESULT([no])
+fi
+
MYSQL_SYS_LARGEFILE
# Types that must be checked AFTER large file support is checked