summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <lenz@mysql.com>2003-05-23 11:38:37 +0200
committerunknown <lenz@mysql.com>2003-05-23 11:38:37 +0200
commitf985f468ef02549ad512ff0eccdc170900f6d0cd (patch)
treed849885e70bec8f89b2d6e512e4d26a64cedb355 /configure.in
parenteb4755c90e6f112277083fedbbe53faf922e65b3 (diff)
downloadmariadb-git-f985f468ef02549ad512ff0eccdc170900f6d0cd.tar.gz
- Portability fix: FreeBSD 4.8-STABLE (480101) and 5.0-CURRENT (500110)
now have a thread safe realpath(3) implementation - added check to only define -DHAVE_BROKEN_REALPATH where required (thanks to Martin Blapp from the FreeBSD team for the patch) configure.in: - FreeBSD 4.8-STABLE (480101) and 5.0-CURRENT (500110) now have a thread safe realpath(3) implementation - added check to only define -DHAVE_BROKEN_REALPATH where required
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index df83f7e715e..8a5ab75a494 100644
--- a/configure.in
+++ b/configure.in
@@ -1025,8 +1025,16 @@ case $SYSTEM_TYPE in
;;
*freebsd*)
echo "Adding fix for interrupted reads"
- CFLAGS="$CFLAGS -DHAVE_BROKEN_REALPATH"
- CXXFLAGS="$CXXFLAGS -DMYSQLD_NET_RETRY_COUNT=1000000 -DHAVE_BROKEN_REALPATH"
+ OSVERSION=`sysctl -a | grep osreldate | awk '{ print $2 }'`
+ if test "$OSVERSION" -gt "480100" && \
+ test "$OSVERSION" -lt "500000" || \
+ test "$OSVERSION" -gt "500109"
+ then
+ CXXFLAGS="$CXXFLAGS -DMYSQLD_NET_RETRY_COUNT=1000000"
+ else
+ CFLAGS="$CFLAGS -DHAVE_BROKEN_REALPATH"
+ CXXFLAGS="$CXXFLAGS -DMYSQLD_NET_RETRY_COUNT=1000000 -DHAVE_BROKEN_REALPATH"
+ fi
;;
*netbsd*)
echo "Adding flag -Dunix"