summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tomas@poseidon.ndb.mysql.com>2005-01-28 02:07:13 +0100
committerunknown <tomas@poseidon.ndb.mysql.com>2005-01-28 02:07:13 +0100
commita6bfe13c6f4fc2e0c2bebea8a295a445aa5765e8 (patch)
tree261279056f83d0b99211fefb02c157965ffddd07 /configure.in
parentcca25e4d4903fbe1df3cd7251d9519c9c9fa376d (diff)
parent418a06308b6abe8462f5942e0dcf4455fb2073b5 (diff)
downloadmariadb-git-a6bfe13c6f4fc2e0c2bebea8a295a445aa5765e8.tar.gz
Merge poseidon.ndb.mysql.com:/home/tomas/mysql-4.1
into poseidon.ndb.mysql.com:/home/tomas/mysql-5.0 Build-tools/Do-compile: Auto merged configure.in: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 8cf0c2c5e58..124e1ce3dcc 100644
--- a/configure.in
+++ b/configure.in
@@ -1531,14 +1531,11 @@ then
fi
fi
-TOOLS_LIBS="$NON_THREADED_CLIENT_LIBS"
-
# Should we use named pthread library ?
AC_MSG_CHECKING("named thread libs:")
if test "$with_named_thread" != "no"
then
LIBS="$with_named_thread $LIBS $with_named_thread"
- TOOLS_LIBS="$with_named_thread $TOOLS_LIBS $with_named_thread"
with_posix_threads="yes"
with_mit_threads="no"
AC_MSG_RESULT("$with_named_thread")
@@ -1557,9 +1554,7 @@ else
then
AC_MSG_CHECKING("for pthread_create in -lpthread");
ac_save_LIBS="$LIBS"
- ac_save_TOOLS_LIBS="$TOOLS_LIBS"
LIBS="$LIBS -lpthread"
- TOOLS_LIBS="$TOOLS_LIBS -lpthread"
AC_TRY_LINK(
[#include <pthread.h>],
[ (void) pthread_create((pthread_t*) 0,(pthread_attr_t*) 0, 0, 0); ],
@@ -1568,7 +1563,6 @@ else
if test "$with_posix_threads" = "no"
then
LIBS=" $ac_save_LIBS -lpthreads"
- TOOLS_LIBS=" $ac_save_TOOLS_LIBS -lpthreads"
AC_MSG_CHECKING("for pthread_create in -lpthreads");
AC_TRY_LINK(
[#include <pthread.h>],
@@ -1579,7 +1573,6 @@ else
then
# This is for FreeBSD
LIBS="$ac_save_LIBS -pthread"
- TOOLS_LIBS="$ac_save_TOOLS_LIBS -pthread"
AC_MSG_CHECKING("for pthread_create in -pthread");
AC_TRY_LINK(
[#include <pthread.h>],
@@ -1590,7 +1583,6 @@ else
then
with_mit_threads="yes"
LIBS="$ac_save_LIBS"
- TOOLS_LIBS="$ac_save_TOOLS_LIBS"
fi
fi
fi
@@ -2656,8 +2648,6 @@ AC_SUBST(sql_union_dirs)
# Some usefull subst
AC_SUBST(CC)
AC_SUBST(GXX)
-#Remove TOOLS_LIBS, because this is included in LIBRARIES
-#AC_SUBST(TOOLS_LIBS)
# Set configuration options for make_binary_distribution
case $SYSTEM_TYPE in