summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <serg@serg.mylan>2006-06-15 21:43:29 +0200
committerunknown <serg@serg.mylan>2006-06-15 21:43:29 +0200
commit33f38c317ad32820d8a0f7bcad665e442f643977 (patch)
tree0b13b37422ece64a7f11d19a77a9ea90a1d88534 /configure.in
parentb15981a40cd7b16c206c4d7fe77df33bb99bbe27 (diff)
downloadmariadb-git-33f38c317ad32820d8a0f7bcad665e442f643977.tar.gz
don't call plugins' configure scripts manually, use AC_CONFIG_SUBDIRS
don't add CFLAGS/CXXFLAGS to ./configure command line in config.status but _do_ add them before calling plugins' configure scripts config/ac-macros/plugins.m4: don't call plugins' configure scripts manually, use AC_CONFIG_SUBDIRS
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 7 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index be6f3c8eaec..120863dafbd 100644
--- a/configure.in
+++ b/configure.in
@@ -2474,10 +2474,6 @@ AC_SUBST(netware_dir)
AC_SUBST(linked_netware_sources)
AM_CONDITIONAL(HAVE_NETWARE, test "$netware_dir" = "netware")
-# Ensure that table handlers gets all modifications to CFLAGS/CXXFLAGS
-export CC CXX CFLAGS CXXFLAGS LD LDFLAGS AR
-ac_configure_args="$ac_configure_args CFLAGS='$CFLAGS' CXXFLAGS='$CXXFLAGS'"
-
if test "$with_server" = "yes" -o "$THREAD_SAFE_CLIENT" != "no"
then
AC_DEFINE([THREAD], [1],
@@ -2527,22 +2523,6 @@ AC_SUBST(CC)
AC_SUBST(GXX)
# Set configuration options for make_binary_distribution
-
-CONF_ARGS=
-case $SYSTEM_TYPE in
- *netware*)
- MAKE_BINARY_DISTRIBUTION_OPTIONS=--no-strip
- CONF_ARGS=--host="$MACHINE_TYPE-$SYSTEM_TYPE"
- ;;
- *)
- MAKE_BINARY_DISTRIBUTION_OPTIONS=
- ;;
-esac
-
-for CONF in $other_configures; do
- (cd `dirname $CONF`; ./`basename $CONF` $CONF_ARGS --build=$build_alias)
-done
-
AC_SUBST(MAKE_BINARY_DISTRIBUTION_OPTIONS)
# Output results
@@ -2559,8 +2539,13 @@ AC_CONFIG_FILES(Makefile extra/Makefile mysys/Makefile dnl
support-files/MacOSX/Makefile mysql-test/Makefile dnl
mysql-test/ndb/Makefile netware/Makefile dnl
include/mysql_version.h plugin/Makefile win/Makefile)
- AC_CONFIG_COMMANDS([default], , test -z "$CONFIG_HEADERS" || echo timestamp > stamp-h)
- AC_OUTPUT
+
+AC_CONFIG_COMMANDS([default], , test -z "$CONFIG_HEADERS" || echo timestamp > stamp-h)
+
+# Ensure that table handlers gets all modifications to CFLAGS/CXXFLAGS
+AC_CONFIG_COMMANDS_POST(ac_configure_args="$ac_configure_args CFLAGS='$CFLAGS' CXXFLAGS='$CXXFLAGS'")
+
+AC_OUTPUT
echo
echo "MySQL has a Web site at http://www.mysql.com/ which carries details on the"