summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <df@pippilotta.erinye.com>2007-06-29 12:19:38 +0200
committerunknown <df@pippilotta.erinye.com>2007-06-29 12:19:38 +0200
commiteefc9a1e30c29c9ca5ea27ead2f7c6521b34a134 (patch)
treede4521fbc271e7023524a09db9e12022bc56f36f /configure.in
parent637d9f1c5061ad0553c549199464c5db98eaec1f (diff)
parentf8034d36ba5670e72374d61ca4901a71adbd6d9f (diff)
downloadmariadb-git-eefc9a1e30c29c9ca5ea27ead2f7c6521b34a134.tar.gz
Merge dev:/data0/mysqldev/my/build-200706140748-5.0.44/mysql-5.0-release
into pippilotta.erinye.com:/shared/home/df/mysql/build/mysql-5.0-build configure.in: Auto merged libmysql/libmysql.c: Auto merged sql/field.cc: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 5f02b5eae63..2bf3e43caae 100644
--- a/configure.in
+++ b/configure.in
@@ -100,14 +100,22 @@ AC_DEFINE_UNQUOTED([NDB_VERSION_STATUS], ["$NDB_VERSION_STATUS"],
# Canonicalize the configuration name.
-SYSTEM_TYPE="$host_vendor-$host_os"
-MACHINE_TYPE="$host_cpu"
+
+# Check whether --with-system-type or --without-system-type was given.
+AC_ARG_WITH(system-type,
+ [ --with-system-type Set the system type, like "sun-solaris10"],
+ [SYSTEM_TYPE="$withval"],
+ [SYSTEM_TYPE="$host_vendor-$host_os"])
+AC_ARG_WITH(machine-type,
+ [ --with-machine-type Set the machine type, like "powerpc"],
+ [MACHINE_TYPE="$withval"],
+ [MACHINE_TYPE="$host_cpu"])
AC_SUBST(SYSTEM_TYPE)
AC_DEFINE_UNQUOTED([SYSTEM_TYPE], ["$SYSTEM_TYPE"],
- [Name of system, eg solaris])
+ [Name of system, eg sun-solaris])
AC_SUBST(MACHINE_TYPE)
AC_DEFINE_UNQUOTED([MACHINE_TYPE], ["$MACHINE_TYPE"],
- [Machine type name, eg sun10])
+ [Machine type name, eg sparc])
# Detect intel x86 like processor
BASE_MACHINE_TYPE=$MACHINE_TYPE