summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@mysql.com>2005-05-18 19:00:21 +0300
committerunknown <monty@mysql.com>2005-05-18 19:00:21 +0300
commitd93806ef7d479f353349862833364f0b332bacea (patch)
treeb3842c1613c97d550be652ce1e354686b5ca35ee /configure.in
parent880bff92639aa80e38a7b3d8686b620b5048de31 (diff)
downloadmariadb-git-d93806ef7d479f353349862833364f0b332bacea.tar.gz
Fix warnings from icc
Added BUILD scripts for icc Fixed (one time) memory leak in grant handling config/ac-macros/misc.m4: Remove warnings flags from icc when compiling with -Werror configure.in: Remove warnings flags from icc when compiling with -Werror extra/replace.c: Fix warnings from icc include/my_dbug.h: Fix warnings from icc sql/gen_lex_hash.cc: Fix warnings from icc sql/mysql_priv.h: Add missing variables sql/mysqld.cc: Fix warnings from icc: - made a lot of variables static - Removing some not used variables - Fixed wrong printf() - removed extern "C" from some functions sql/spatial.h: Fix warnings from icc sql/sql_acl.cc: Fixed memory leak sql/sql_lex.cc: Fix warnings from icc sql/sql_lex.h: Fix warnings from icc
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 980bb461924..26e30486ba5 100644
--- a/configure.in
+++ b/configure.in
@@ -1965,9 +1965,12 @@ AC_LANG_CPLUSPLUS
# with respect to ANSI C++
# We also remove the -fbranch-probabilities option as this will give warnings
# about not profiled code, which confuses configure
+# We also must remove -W and -Wcheck which on icc produces warnings that
+# we don't want to catch with -Werror
+
if test "$ac_cv_prog_gxx" = "yes" -a "$with_other_libc" = "no"
then
- CXXFLAGS=`echo "$CXXFLAGS -Werror" | sed 's/-fbranch-probabilities//'`
+ CXXFLAGS=`echo "$CXXFLAGS -Werror" | sed -e 's/-fbranch-probabilities//; s/-Wall//; s/-Wcheck//'`
fi
AC_TRY_COMPILE(
@@ -2002,7 +2005,7 @@ AC_LANG_SAVE
AC_LANG_CPLUSPLUS
if test "$ac_cv_prog_gxx" = "yes" -a "$with_other_libc" = "no"
then
- CXXFLAGS=`echo "$CXXFLAGS -Werror" | sed 's/-fbranch-probabilities//'`
+ CXXFLAGS=`echo "$CXXFLAGS -Werror" | sed -e 's/-fbranch-probabilities//; s/-Wall//; s/-Wcheck//'`
fi
AC_TRY_COMPILE(
[#undef inline
@@ -2035,7 +2038,7 @@ AC_LANG_SAVE
AC_LANG_CPLUSPLUS
if test "$ac_cv_prog_gxx" = "yes" -a "$with_other_libc" = "no"
then
- CXXFLAGS=`echo "$CXXFLAGS -Werror" | sed 's/-fbranch-probabilities//'`
+ CXXFLAGS=`echo "$CXXFLAGS -Werror" | sed -e 's/-fbranch-probabilities//; s/-Wall//; s/-Wcheck//'`
fi
AC_TRY_COMPILE(
[#undef inline