summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <joerg@debian.(none)>2007-04-20 10:51:53 +0200
committerunknown <joerg@debian.(none)>2007-04-20 10:51:53 +0200
commit26aba3fb2c2924f530d258593abecda5d3a90a22 (patch)
tree6e93d32759016b378bd4b5bb6020d8293a6323f4 /configure.in
parent0e42267fa0975afcf42ac0e21ba7d308c93d17ec (diff)
downloadmariadb-git-26aba3fb2c2924f530d258593abecda5d3a90a22.tar.gz
configure.in : Ensure that "icheck" is really the ABI checker,
not some other tool (file system checker on Tru64). Patch originally supplied by Peter O'Gorman, slightly modified by me. Bug#27739 "build fails on Tru64 due to icheck test in configure" configure.in: We use "icheck" as a tool to check against ABI changes. However, some systems (like Tru64) have "icheck" as a file system checker. So if "icheck" is found, it should be verified that this really is the ABI checker and not some other tool. Patch originally supplied by Peter O'Gorman, slightly modified by me. Bug#27739 "build fails on Tru64 due to icheck test in configure"
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0c2d20e3feb..a29329707af 100644
--- a/configure.in
+++ b/configure.in
@@ -459,6 +459,22 @@ AC_SUBST(MAKEINDEX)
# icheck, used for ABI check
AC_PATH_PROG(ICHECK, icheck, no)
+# "icheck" is also the name of a file system check program on Tru64.
+# Verify the program found is really the interface checker.
+if test "x$ICHECK" != "xno"
+then
+ AC_MSG_CHECKING(if $ICHECK works as expected)
+ echo "int foo;" > conftest.h
+ $ICHECK --canonify -o conftest.ic conftest.h 2>/dev/null
+ if test -f "conftest.ic"
+ then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ ICHECK=no
+ fi
+ rm -f conftest.ic conftest.h
+fi
AC_SUBST(ICHECK)
# Lock for PS