summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <istruewing@synthia.local>2007-06-30 00:45:24 +0200
committerunknown <istruewing@synthia.local>2007-06-30 00:45:24 +0200
commitca731030098b04431d39ad95a1fa4244944e8b35 (patch)
treead7c0b74bb219157c36bdc815b52d05ec8dd1ef7 /configure.in
parenta0fa27cf359397d721272635482a7d03687ad241 (diff)
parenta9e5e4c5f8464c725e49fcd43b6544e4b503163d (diff)
downloadmariadb-git-ca731030098b04431d39ad95a1fa4244944e8b35.tar.gz
Merge synthia.local:/home/mydev/mysql-5.1-amain
into synthia.local:/home/mydev/mysql-5.1-axmrg configure.in: Auto merged libmysql/libmysql.c: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 04a8d045053..e2857cf43e3 100644
--- a/configure.in
+++ b/configure.in
@@ -71,14 +71,22 @@ AC_SUBST(AVAILABLE_LANGUAGES)
# Canonicalize the configuration name.
-SYSTEM_TYPE="$host_vendor-$host_os"
-MACHINE_TYPE="$host_cpu"
+
+# Check whether --with-system-type or --without-system-type was given.
+AC_ARG_WITH(system-type,
+ [ --with-system-type Set the system type, like "sun-solaris10"],
+ [SYSTEM_TYPE="$withval"],
+ [SYSTEM_TYPE="$host_vendor-$host_os"])
+AC_ARG_WITH(machine-type,
+ [ --with-machine-type Set the machine type, like "powerpc"],
+ [MACHINE_TYPE="$withval"],
+ [MACHINE_TYPE="$host_cpu"])
AC_SUBST(SYSTEM_TYPE)
AC_DEFINE_UNQUOTED([SYSTEM_TYPE], ["$SYSTEM_TYPE"],
- [Name of system, eg solaris])
+ [Name of system, eg sun-solaris])
AC_SUBST(MACHINE_TYPE)
AC_DEFINE_UNQUOTED([MACHINE_TYPE], ["$MACHINE_TYPE"],
- [Machine type name, eg sun10])
+ [Machine type name, eg sparc])
# Detect intel x86 like processor
BASE_MACHINE_TYPE=$MACHINE_TYPE