summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKent Boortz <kent.boortz@sun.com>2010-02-02 23:29:14 +0100
committerKent Boortz <kent.boortz@sun.com>2010-02-02 23:29:14 +0100
commit673ec7b24d1e4c8806d964ef262f39fadc84da70 (patch)
treedd10b45c1182c76c4290cf04677a421c21746d9d /configure.in
parent679de2bb5eb36c900c0f9db189283e73ab4acbcc (diff)
downloadmariadb-git-673ec7b24d1e4c8806d964ef262f39fadc84da70.tar.gz
Changes to be able to create source TAR packages with longer
path names than 99 characters, using the USTAR format of the resulting source TAR. To be able to specify the use of USTAR when creating the source TAR, we needed both to update the GNU autotools version requirements slightly, and update the initiation of the tools to use more modern constructs.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 14 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 38eb511ac18..eeb1da8670a 100644
--- a/configure.in
+++ b/configure.in
@@ -1,17 +1,23 @@
dnl -*- ksh -*-
dnl Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.52)dnl Minimum Autoconf version required.
+# Minimum Autoconf version required.
+AC_PREREQ(2.59)
-AC_INIT(sql/mysqld.cc)
-AC_CANONICAL_SYSTEM
-# The Docs Makefile.am parses this line!
-# remember to also update version.c in ndb
-#
+# Remember to also update version.c in ndb.
# When changing major version number please also check switch statement
# in mysqlbinlog::check_master_version().
-AM_INIT_AUTOMAKE(mysql, 5.1.43)
-AM_CONFIG_HEADER([include/config.h:config.h.in])
+AC_INIT([MySQL Server], [5.1.43], [], [mysql])
+AC_CONFIG_SRCDIR([sql/mysqld.cc])
+AC_CANONICAL_SYSTEM
+# USTAR format gives us the possibility to store longer path names in
+# TAR files, the path name is split into two parts, a 155 chacater
+# first part and a 100 character second part.
+AM_INIT_AUTOMAKE([1.9 tar-ustar])
+LT_INIT
+LT_PREREQ([1.5.6])
+
+AM_CONFIG_HEADER([include/config.h])
# Request support for automake silent-rules if available.
# Default to verbose output. One can use the configure-time