summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@donna.mysql.com>2001-02-07 23:27:19 +0200
committerunknown <monty@donna.mysql.com>2001-02-07 23:27:19 +0200
commit455ac66af81bf2a85f48e4e59b23bd988ba4dcb0 (patch)
treed7fa348f41efb0b9fb57e0fe2b6be333f71433cb /configure.in
parentf816d6f16d5c4df073cf0bed40de07286f6c6cd5 (diff)
downloadmariadb-git-455ac66af81bf2a85f48e4e59b23bd988ba4dcb0.tar.gz
Force sockets to be blocking on HPUX 11.0
Changed BITMAP to MY_BITMAP to avoid type conflict on windows configure.in: Force sockets to be blocking on HPUX 11.0 include/my_bitmap.h: Changed BITMAP to MY_BITMAP to avoid type conflict on windows mysys/my_bitmap.c: Changed BITMAP to MY_BITMAP to avoid type conflict on windows mysys/my_init.c: Removed LOCK_bitmap sql/mysql_priv.h: Changed BITMAP to MY_BITMAP to avoid type conflict on windows sql/mysqld.cc: Changed BITMAP to MY_BITMAP to avoid type conflict on windows sql/violite.c: Force sockets to be blocking on HPUX 11.0
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 828ff2a315d..fc175fbce47 100644
--- a/configure.in
+++ b/configure.in
@@ -709,8 +709,8 @@ case $SYSTEM_TYPE in
;;
*hpux11.*)
echo "Enabling pread/pwrite workaround for hpux 11"
- CFLAGS="$CFLAGS -DHAVE_BROKEN_PREAD -DDONT_USE_FINITE -DHAVE_BROKEN_GETPASS"
- CXXFLAGS="$CXXFLAGS -DHAVE_BROKEN_PREAD -DDONT_USE_FINITE -D_INCLUDE_LONGLONG"
+ CFLAGS="$CFLAGS -DHAVE_BROKEN_PREAD -DDONT_USE_FINITE -DHAVE_BROKEN_GETPASS -DNO_FCNTL_NONBLOCK"
+ CXXFLAGS="$CXXFLAGS -DHAVE_BROKEN_PREAD -DDONT_USE_FINITE -D_INCLUDE_LONGLONG -DNO_FCNTL_NONBLOCK"
if test "$with_named_thread" = "no"
then
echo "Using --with-named-thread=-lpthread"