summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tim@threads.polyesthetic.msg>2001-04-14 13:04:20 -0400
committerunknown <tim@threads.polyesthetic.msg>2001-04-14 13:04:20 -0400
commit7cabdf0446534e40e9fac0625dda0d5d4ea21a5b (patch)
tree515ac8c5735717e0710952c11274a7169667cd2d /configure.in
parent46decdde430578a72e5852a62ae51f59d80f582f (diff)
downloadmariadb-git-7cabdf0446534e40e9fac0625dda0d5d4ea21a5b.tar.gz
Try to make MySQL compile under Cygwin.
Bug fix for Dec OSF on Alpha. Minor bug fix for server RPM. Tweak RPM support for mysqld-max. configure.in: Try to identify FIND_PROC for Cygwin. Thanks to Pete French <pfrench@firstcallgroup.co.uk> for the initial patch. Add -mieee to C(XX)FLAGS on Dec OSF for alpha, to fix bug w/ floating point arithmetic. Thanks to nick@netability.ie for the heads up. Don't make mysql-test depend on --with-bench; always build it. Thanks to smurf@play.smurf.noris.de for the patch. include/global.h: Fix #defines if we are using __CYGWIN__. Thanks to Pete French <pfrench@firstcallgroup.co.uk> for the initial patch. support-files/mysql.spec.sh: Change %preun script so that it doesn't shut down mysqld after an upgrade. Thanks to Andy Dustman for the patch. Add a %post Max script to restart mysqld after upgrading to mysqld-max.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 807de749b73..f0c2d30c035 100644
--- a/configure.in
+++ b/configure.in
@@ -359,6 +359,9 @@ else
*darwin*)
FIND_PROC="$PS -uaxww | grep mysqld | grep \" \$\$PID \" > /dev/null"
;;
+ *cygwin*)
+ FIND_PROC="$PS -e | grep mysqld | grep \" \$\$PID \" > /dev/null"
+ ;;
*)
AC_MSG_ERROR([Could not find the right ps switches. Which OS is this ?. See the Installation chapter in the Reference Manual.])
esac
@@ -795,6 +798,15 @@ case $SYSTEM_TYPE in
CFLAGS="$CFLAGS -Wa,-many -DUNDEF_HAVE_INITGROUPS"
CXXFLAGS="$CXXFLAGS -Wa,-many -DUNDEF_HAVE_INITGROUPS"
;;
+dnl Is this the right match for DEC OSF on alpha?
+ *dec-osf*)
+ if test "$ac_cv_prog_gcc" = "yes" && test "$host_cpu" = "alpha"
+ then
+ echo "Adding defines for DEC OSF on alpha"
+ CFLAGS="$CFLAGS -mieee"
+ CXXFLAGS="$CXXFLAGS -mieee"
+ fi
+ ;;
esac
@@ -1605,10 +1617,11 @@ AC_ARG_WITH(bench,
if test "$with_bench" = "yes"
then
- bench_dirs="sql-bench mysql-test"
+ bench_dirs="sql-bench"
else
bench_dirs=""
fi
+bench_dirs="$bench_dirs mysql-test"
AC_SUBST(bench_dirs)
# Don't build readline, i have it already