summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNarayanan V <v.narayanan@sun.com>2008-06-17 17:57:04 +0530
committerNarayanan V <v.narayanan@sun.com>2008-06-17 17:57:04 +0530
commit72b74d581262c08233db28999e85fb46eb94811a (patch)
treeb0d5eb8e666ebabca0056cca48f0e34cc04d904c /configure.in
parent71d26d2ff19f649e70d953b0020378ccdd96278d (diff)
downloadmariadb-git-72b74d581262c08233db28999e85fb46eb94811a.tar.gz
WL#4380
added a rule that use gcc to generate preprocessor output (gcc -E) that can be then compared to a already generated output using the diff utility. Ran make test on the repository to verify changes. Makefile.am: Added a rule for checking that the abi/api has not changed. The following steps are followed in the rule in makefile.am 1) Generate preprocessor output for the files that need to be tested for abi/api changes. use -nostdinc to prevent generation of preprocessor output for system headers. This results in messages in stderr saying that these headers were not found. Redirect the stderr output to /dev/null to prevent seeing these messages. 2) sed the output to remove blank lines and lines that begin with # (The header information is retained to enable easy analysis of abi diffs at a later stage). 3) diff the generated file and the canons (.pp files already in the repository). 4) delete the .out file that is generated. If the diff fails, the generated file is not removed. This will be useful for analysis of ABI differences (e.g. using a visual diff tool). A ABI change that causes a build to fail will always be accompanied by new canons (.out files). The .out files that are not removed will be replaced as the new .pp files. e.g. If include/mysql/plugin.h has an ABI change then this rule would leave a include/mysql/plugin.out file. A developer with a justified API change will then do a mv include/mysql/plugin.out include/mysql/plugin.pp to replace the old canons with the new ones. configure.in: 1) Removed the part of the file that was icheck related. 2) Added an entry for the configure variable DIFF include/mysql.h.pp: The pre-processor output canon file for include/mysql.h include/mysql/plugin.h.pp: The pre-processor output canon file for include/mysql/plugin.h include/mysql_h.ic: since the icheck target has been removed, this file need no longer be present in the repository sql/mysql_priv.h.pp: The pre-processor output canon file for sql/mysql_priv.h
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 1 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index af23b6035eb..33266a35b33 100644
--- a/configure.in
+++ b/configure.in
@@ -419,6 +419,7 @@ AC_PATH_PROG(SED, sed, sed)
AC_PATH_PROG(CMP, cmp, cmp)
AC_PATH_PROG(CHMOD, chmod, chmod)
AC_PATH_PROG(HOSTNAME, hostname, hostname)
+AC_PATH_PROG(DIFF, diff, diff)
# Check for a GNU tar named 'gtar', or 'gnutar' (MacOS X) and
# fall back to 'tar' otherwise and hope that it's a GNU tar as well
AC_CHECK_PROGS(TAR, gnutar gtar tar)
@@ -443,26 +444,6 @@ AC_SUBST(HOSTNAME)
AC_SUBST(PERL)
AC_SUBST(PERL5)
-# icheck, used for ABI check
-AC_PATH_PROG(ICHECK, icheck, no)
-# "icheck" is also the name of a file system check program on Tru64.
-# Verify the program found is really the interface checker.
-if test "x$ICHECK" != "xno"
-then
- AC_MSG_CHECKING(if $ICHECK works as expected)
- echo "int foo;" > conftest.h
- $ICHECK --canonify -o conftest.ic conftest.h 2>/dev/null
- if test -f "conftest.ic"
- then
- AC_MSG_RESULT(yes)
- else
- AC_MSG_RESULT(no)
- ICHECK=no
- fi
- rm -f conftest.ic conftest.h
-fi
-AC_SUBST(ICHECK)
-
# Lock for PS
AC_PATH_PROG(PS, ps, ps)
AC_MSG_CHECKING("how to check if pid exists")