summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2005-04-27 12:24:17 +0200
committerunknown <msvensson@neptunus.(none)>2005-04-27 12:24:17 +0200
commitabf4e93d8285c8e73df85f3056fd7ce81cafad13 (patch)
tree2b1dd4bcbd782210cb0ea196deb176f4c35915d1 /configure.in
parent3ce2f6f40a6cb6170433058fbfc644cafddf6030 (diff)
parentecfae64d65c54004b2330669f141d44e48d4742c (diff)
downloadmariadb-git-abf4e93d8285c8e73df85f3056fd7ce81cafad13.tar.gz
Merge neptunus.(none):/home/msvensson/mysql/bug8162
into neptunus.(none):/home/msvensson/mysql/mysql-4.1 configure.in: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index c9143d21a0f..bc058265b9a 100644
--- a/configure.in
+++ b/configure.in
@@ -2407,17 +2407,24 @@ then
compile_readline=yes
AC_DEFINE_UNQUOTED(USE_NEW_READLINE_INTERFACE, 1)
else
+ # Use system readline library
AC_LANG_SAVE
AC_LANG_CPLUSPLUS
MYSQL_CHECK_LIBEDIT_INTERFACE
MYSQL_CHECK_NEW_RL_INTERFACE
MYSQL_CHECK_READLINE_DECLARES_HIST_ENTRY
AC_LANG_RESTORE
- if [test "$mysql_cv_new_rl_interface" = "yes"] || [test "$mysql_cv_libedit_interface" = "no"]
+ if [test "$mysql_cv_new_rl_interface" = "yes"]
then
+ # Use the new readline interface
readline_link="-lreadline"
- else
+ elif [test "$mysql_cv_libedit_interface" = "yes"]; then
+ # Use libedit
readline_link="-ledit"
+ else
+ AC_MSG_ERROR([Could not find system readline or libedit libraries
+ Use --with-readline or --with-libedit to use the bundled
+ versions of libedit or readline])
fi
fi
fi