summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mysql.com>2008-10-01 22:55:23 +0200
committerSergei Golubchik <serg@mysql.com>2008-10-01 22:55:23 +0200
commitc7a304a26499596a62eb9c27ba60f1e076ef90de (patch)
tree6012bf21365540fe2877311e79b8df9a0643e22a /configure.in
parent6484f5a11f0f3d82d2bd1f60143cc2cd3c2c399b (diff)
downloadmariadb-git-c7a304a26499596a62eb9c27ba60f1e076ef90de.tar.gz
Implement conditional building correctly.
automake *must* know all sources in advance, listing a file in EXTRA_DIST doesn't make it a source, which breakes dependency tracking (.Po files aren't included)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index ffc77b29434..50b1a369825 100644
--- a/configure.in
+++ b/configure.in
@@ -2701,14 +2701,12 @@ if test "$with_server" = "yes" -o "$THREAD_SAFE_CLIENT" != "no"
then
AC_DEFINE([THREAD], [1],
[Define if you want to have threaded code. This may be undef on client code])
- # Avoid _PROGRAMS names
- THREAD_LOBJECTS="thr_alarm.o thr_lock.o thr_mutex.o thr_rwlock.o my_pthread.o my_thr_init.o mf_keycache.o waiting_threads.o"
- AC_SUBST(THREAD_LOBJECTS)
server_scripts="mysqld_safe mysql_install_db"
sql_server_dirs="strings mysys dbug extra regex"
sql_server="vio sql"
fi
+AM_CONDITIONAL(THREAD, test "$with_server" = "yes" -o "$THREAD_SAFE_CLIENT" != "no")
# IMPORTANT - do not modify LIBS past this line - this hack is the only way
# I know to add the static NSS magic if we have static NSS libraries with