summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2005-04-27 12:56:01 +0200
committerunknown <msvensson@neptunus.(none)>2005-04-27 12:56:01 +0200
commit0e29519b2b4f06f2e37b59c7e9359331c15e83a4 (patch)
tree922f8cbd12ff26fed829ed3fbe11e44e2ea2923f /configure.in
parent49b448ae5a91ed9c0dde57ecd1de724bf517d904 (diff)
parent78f89a729a962f7a88869a3d5e50ca493391b2a4 (diff)
downloadmariadb-git-0e29519b2b4f06f2e37b59c7e9359331c15e83a4.tar.gz
Merge from 4.1 to 5.0
client/mysql.cc: Auto merged include/my_pthread.h: Auto merged ndb/src/ndbapi/ndberror.c: Auto merged sql/examples/ha_archive.cc: Auto merged sql/examples/ha_archive.h: Auto merged BUILD/SETUP.sh: Manual merge of conflicts -DBIG_TABLES removed set by configure using --with-big-tables configure.in: manual merge mysql-test/r/archive.result: Manual merge mysql-test/t/archive.test: Manual merge
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 559589d9c05..07ce041b283 100644
--- a/configure.in
+++ b/configure.in
@@ -116,6 +116,7 @@ AC_SUBST(SAVE_LDFLAGS)
AC_SUBST(SAVE_CXXLDFLAGS)
AC_SUBST(CXXLDFLAGS)
+AC_PREREQ(2.58)dnl Minimum Autoconf version required.
#AC_ARG_PROGRAM # Automaticly invoked by AM_INIT_AUTOMAKE
@@ -2386,17 +2387,24 @@ then
compile_readline=yes
AC_DEFINE_UNQUOTED(USE_NEW_READLINE_INTERFACE, 1)
else
+ # Use system readline library
AC_LANG_SAVE
AC_LANG_CPLUSPLUS
MYSQL_CHECK_LIBEDIT_INTERFACE
MYSQL_CHECK_NEW_RL_INTERFACE
MYSQL_CHECK_READLINE_DECLARES_HIST_ENTRY
AC_LANG_RESTORE
- if [test "$mysql_cv_new_rl_interface" = "yes"] || [test "$mysql_cv_libedit_interface" = "no"]
+ if [test "$mysql_cv_new_rl_interface" = "yes"]
then
+ # Use the new readline interface
readline_link="-lreadline"
- else
+ elif [test "$mysql_cv_libedit_interface" = "yes"]; then
+ # Use libedit
readline_link="-ledit"
+ else
+ AC_MSG_ERROR([Could not find system readline or libedit libraries
+ Use --with-readline or --with-libedit to use the bundled
+ versions of libedit or readline])
fi
fi
fi