summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@hundin.mysql.fi>2001-09-29 05:14:09 +0300
committerunknown <monty@hundin.mysql.fi>2001-09-29 05:14:09 +0300
commitad9c7236a026395e5d7e6faf7ec83689f631ca40 (patch)
tree081f21c10af99eabc7252a352de0831a0b80e34e /configure.in
parentda6f235ca0a21fce9f20818d6c216ed6aa454eaa (diff)
downloadmariadb-git-ad9c7236a026395e5d7e6faf7ec83689f631ca40.tar.gz
Fix for make dist
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 8528ff0b9a3..8f0b0ee6439 100644
--- a/configure.in
+++ b/configure.in
@@ -2181,7 +2181,17 @@ EOF
then
sql_server_dirs="innobase $sql_server_dirs"
echo "CONFIGURING FOR INNODB"
- (cd innobase && sh ./configure) \
+ if test ! -d "innobase"; then
+ # This should only happen when doing a VPATH build
+ echo "NOTICE: I have to make the Innobase directory: `pwd`/innobase"
+ mkdir "innobase" || exit 1
+ fi
+ rel_srcdir=
+ case "$srcdir" in
+ /* ) rel_srcdir="$srcdir" ;;
+ * ) rel_srcdir="../$srcdir" ;;
+ esac
+ (cd innobase && sh $rel_srcdir/innobase/configure) \
|| AC_MSG_ERROR([could not configure INNODB])
echo "END OF INNODB CONFIGURATION"