summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <jimw@mysql.com>2005-11-17 13:37:30 -0800
committerunknown <jimw@mysql.com>2005-11-17 13:37:30 -0800
commit016fe413b44bc07d0ebb7adc14bf0c509885e673 (patch)
tree0469b3757df7cbb4eec77b1666376cc27926bcff /configure.in
parent57ad6b20ed8b22b010af1c354b23591570f12b09 (diff)
parent421dadf74fd436b10b6bad46d8f370748a4d318b (diff)
downloadmariadb-git-016fe413b44bc07d0ebb7adc14bf0c509885e673.tar.gz
Merge mysql.com:/home/jimw/my/mysql-4.1-clean
into mysql.com:/home/jimw/my/mysql-5.0-clean client/mysql.cc: Auto merged configure.in: Auto merged mysql-test/t/mix_innodb_myisam_binlog.test: Auto merged mysql-test/r/mix_innodb_myisam_binlog.result: Resolve conflict sql/item_func.cc: Resolve conflict sql/sql_show.cc: Resolve conflicts
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 52dec85df8c..cf132e4f4cc 100644
--- a/configure.in
+++ b/configure.in
@@ -1587,6 +1587,19 @@ if expr "$SYSTEM_TYPE" : ".*netware.*" > /dev/null; then
OPTIMIZE_CXXFLAGS="-O3 -DNDEBUG"
fi
+# If the user specified CFLAGS, we won't add any optimizations
+if test -n "$SAVE_CFLAGS"
+then
+ OPTIMIZE_CFLAGS=""
+ DEBUG_OPTIMIZE_CC=""
+fi
+# Ditto for CXXFLAGS
+if test -n "$SAVE_CXXFLAGS"
+then
+ OPTIMIZE_CXXFLAGS=""
+ DEBUG_OPTIMIZE_CXX=""
+fi
+
AC_ARG_WITH(debug,
[ --without-debug Build a production version without debugging code],
[with_debug=$withval],