summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2006-03-20 21:35:05 +0100
committerunknown <msvensson@neptunus.(none)>2006-03-20 21:35:05 +0100
commit6219f23b940380307127d3a083404665b7bb13bf (patch)
treebabe7a6eb2084eeec3f356cc60ed196117ffd072 /configure.in
parent53862e6060a3f5e57c5bf628be94abfdbac145ad (diff)
parent680ba0b7d93a2429cc24ae6e397e0a789b4e269d (diff)
downloadmariadb-git-6219f23b940380307127d3a083404665b7bb13bf.tar.gz
Merge neptunus.(none):/home/msvensson/mysql/mysql-5.0
into neptunus.(none):/home/msvensson/mysql/bug11835/my50-bug11835 client/mysqltest.c: Auto merged configure.in: Auto merged mysql-test/mysql-test-run.pl: Auto merged sql/item_func.cc: Auto merged sql/sql_udf.cc: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in44
1 files changed, 30 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 4ff90bb39bb..60e34eeb9f5 100644
--- a/configure.in
+++ b/configure.in
@@ -1547,16 +1547,37 @@ else
fi
#---END:
-# Check for dlopen, needed for user definable functions
-# This must be checked after threads on AIX
-# We only need this for mysqld, not for the clients.
+# dlopen, dlerror
+case "$with_mysqld_ldflags " in
+
+ *"-static "*)
+ # No need to check for dlopen when mysqld is linked with
+ # -all-static or -static as it won't be able to load any functions.
+ # NOTE! It would be better if it was possible to test if dlopen
+ # can be used, but a good way to test it couldn't be found
+
+ ;;
+
+ *)
+ # Check for dlopen, needed for user definable functions
+ # This must be checked after threads on AIX
+ # We only need this for mysqld, not for the clients.
+
+ my_save_LIBS="$LIBS"
+ LIBS=""
+ AC_CHECK_LIB(dl,dlopen)
+ LIBDL=$LIBS
+ LIBS="$my_save_LIBS"
+ AC_SUBST(LIBDL)
+
+ my_save_LIBS="$LIBS"
+ LIBS="$LIBS $LIBDL"
+ AC_CHECK_FUNCS(dlopen dlerror)
+ LIBS="$my_save_LIBS"
+
+ ;;
+esac
-my_save_LIBS="$LIBS"
-LIBS=""
-AC_CHECK_LIB(dl,dlopen)
-LIBDL=$LIBS
-LIBS="$my_save_LIBS"
-AC_SUBST(LIBDL)
# System characteristics
case $SYSTEM_TYPE in
@@ -1925,11 +1946,6 @@ then
fi]
)
-my_save_LIBS="$LIBS"
-LIBS="$LIBS $LIBDL"
-AC_CHECK_FUNCS(dlopen dlerror)
-LIBS="$my_save_LIBS"
-
# Check definition of gethostbyaddr_r (glibc2 defines this with 8 arguments)
ac_save_CXXFLAGS="$CXXFLAGS"
AC_CACHE_CHECK([style of gethost* routines], mysql_cv_gethost_style,