summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <lenz@mysql.com>2003-09-12 12:42:34 +0200
committerunknown <lenz@mysql.com>2003-09-12 12:42:34 +0200
commitf61743dea88b0581a12a0f1db673ea3ef3e699c5 (patch)
treeaa764437ec69be153252826ff2bde43aaa638f93 /configure.in
parent4d2d0eb5d8b39c3d892b3ca365497aa4a16115e1 (diff)
downloadmariadb-git-f61743dea88b0581a12a0f1db673ea3ef3e699c5.tar.gz
Portability fixes:
- removed "-traditional-cpp" from the darwin6 compile flags, as it broke compilation with gcc-3.3 on Mac OS X and does not seem to be required in general. - make sure to link libmysqld/examples/mysqltest.c with a C++ compiler, as the embedded server library (libmysqld.a) includes C++ code. This broke compilation with non-gcc compilers. configure.in: - removed "-traditional-cpp" from the darwin6 compile flags, as it broke compilation with gcc-3.3 and does not seem to be required in general. libmysqld/examples/Makefile.am: - make sure to link mysqltest.c with a C++ compiler, as the embedded server library (libmysqld.a) includes C++ code.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index fb573f0030f..8ec42366ed9 100644
--- a/configure.in
+++ b/configure.in
@@ -1017,7 +1017,7 @@ case $SYSTEM_TYPE in
*darwin6*)
if test "$ac_cv_prog_gcc" = "yes"
then
- FLAGS="-traditional-cpp -DHAVE_DARWIN_THREADS -D_P1003_1B_VISIBLE -DSIGNAL_WITH_VIO_CLOSE -DSIGNALS_DONT_BREAK_READ -DHAVE_BROKEN_REALPATH -DFN_NO_CASE_SENCE"
+ FLAGS="-DHAVE_DARWIN_THREADS -D_P1003_1B_VISIBLE -DSIGNAL_WITH_VIO_CLOSE -DSIGNALS_DONT_BREAK_READ -DHAVE_BROKEN_REALPATH -DFN_NO_CASE_SENCE"
CFLAGS="$CFLAGS $FLAGS"
CXXFLAGS="$CXXFLAGS $FLAGS"
MAX_C_OPTIMIZE="-O"