summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2005-11-03 10:37:49 +0100
committerunknown <msvensson@neptunus.(none)>2005-11-03 10:37:49 +0100
commitf8aa1db39ca5a5dfb8027706b73c644e5679d310 (patch)
tree054a50e63aeabf383220286393ed2a2821af02db /configure.in
parent11632315c8493725bc80b160dfd3036f15b5a2cf (diff)
downloadmariadb-git-f8aa1db39ca5a5dfb8027706b73c644e5679d310.tar.gz
Bug#13957 yassl: opensrv6c compile failure
- Added some ifdefs and turn off auto template instantiation, use explicit template instantiation configure.in: Use -Tno_implict to indicate that we specifiy which template should be instantiated. Turn on HAVE_EXPLICIT_TEMPLATE_INSTATNTIATION extra/yassl/src/socket_wrapper.cpp: Include sys/filio.h if __SCO_VERSION__ is defined extra/yassl/src/timer.cpp: Dont' include files from within namespace yaSSL.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2179c82e2e5..5e1cc5f307d 100644
--- a/configure.in
+++ b/configure.in
@@ -334,6 +334,10 @@ case "$target_os" in
# Use the built-in alloca()
CFLAGS="$CFLAGS -Kalloca"
CXXFLAGS="$CFLAGS -Kalloca"
+ # Use no_implicit for templates
+ CXXFLAGS="$CXXFLAGS -Tno_implicit"
+ AC_DEFINE([HAVE_EXPLICIT_TEMPLATE_INSTANTIATION],
+ [1], [Defined by configure. Use explicit template instantiation.])
fi
;;
esac