summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexey Kopytov <Alexey.Kopytov@Sun.com>2009-06-26 17:52:44 +0400
committerAlexey Kopytov <Alexey.Kopytov@Sun.com>2009-06-26 17:52:44 +0400
commit67996ebc08f129710260ccc48c08d5671f55b985 (patch)
tree5344dfa9899c0fd7bc94c66acfd4186973c6b22c /configure.in
parentac47882b007d76484a00bdcc9752333330a2fd67 (diff)
parente544285dc2182eb9f6da7a77d2730747a87a2e69 (diff)
downloadmariadb-git-67996ebc08f129710260ccc48c08d5671f55b985.tar.gz
Automerge.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 18 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index d323ce9f726..a395d64206a 100644
--- a/configure.in
+++ b/configure.in
@@ -1624,7 +1624,7 @@ esac
# Build optimized or debug version ?
# First check for gcc and g++
-if test "$ac_cv_prog_gcc" = "yes"
+if test "$GCC" = "yes"
then
DEBUG_CFLAGS="-g"
DEBUG_OPTIMIZE_CC="-O"
@@ -1632,9 +1632,16 @@ then
else
DEBUG_CFLAGS="-g"
DEBUG_OPTIMIZE_CC=""
- OPTIMIZE_CFLAGS="-O"
+ case $SYSTEM_TYPE in
+ *solaris*)
+ OPTIMIZE_CFLAGS="-O1"
+ ;;
+ *)
+ OPTIMIZE_CFLAGS="-O"
+ ;;
+ esac
fi
-if test "$ac_cv_prog_cxx_g" = "yes"
+if test "$GXX" = "yes"
then
DEBUG_CXXFLAGS="-g"
DEBUG_OPTIMIZE_CXX="-O"
@@ -1642,7 +1649,14 @@ then
else
DEBUG_CXXFLAGS="-g"
DEBUG_OPTIMIZE_CXX=""
- OPTIMIZE_CXXFLAGS="-O"
+ case $SYSTEM_TYPE in
+ *solaris*)
+ OPTIMIZE_CXXFLAGS="-O1"
+ ;;
+ *)
+ OPTIMIZE_CXXFLAGS="-O"
+ ;;
+ esac
fi
case $SYSTEM_TYPE in