summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <mtaylor@qualinost.(none)>2007-01-18 16:28:47 -0800
committerunknown <mtaylor@qualinost.(none)>2007-01-18 16:28:47 -0800
commit687f6b22254c1cd1747e1ec651a3a7675b808faf (patch)
tree75f26b7731a967f7b967f5261627babbb7e5bb6b /configure.in
parentf9146c1595c54ede2e3421ad9d709a9c7fed1735 (diff)
downloadmariadb-git-687f6b22254c1cd1747e1ec651a3a7675b808faf.tar.gz
Added configure section to deal with actually versioning symbols.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9402c8d1876..f73f08f85fc 100644
--- a/configure.in
+++ b/configure.in
@@ -388,6 +388,14 @@ if $LD --version 2>/dev/null|grep -q GNU; then
fi
AC_SUBST(LD_VERSION_SCRIPT)
+# libndbclient versioning when linked with GNU ld.
+if $LD --version 2>/dev/null|grep -q GNU; then
+ NDB_LD_VERSION_SCRIPT="-Wl,--version-script=\$(top_builddir)/storage/ndb/src/libndb.ver"
+ AC_CONFIG_FILES(storage/ndb/src/libndb.ver)
+fi
+AC_SUBST(NDB_LD_VERSION_SCRIPT)
+
+
# Avoid bug in fcntl on some versions of linux
AC_MSG_CHECKING([if we should use 'skip-external-locking' as default for $target_os])
# Any variation of Linux